USB2.0-Serial not showing up under Port

Full disclosure: I'm very new to this.

I’m trying to connect to pronterface with my MacBook, and the usb name is USB2.0-Serial. I don’t know what to put in the Port section, 2.0 isn’t working. All I can find is stuff on connecting to windows. Followed the mac OSX download tutorial. Didn’t see anything different. Still can’t connect to the USB port in pronterface. I see the sanguino folder in my hardware folder in documents, but it’s not showing up in boards. I tried connecting to a different USB on this Mac and nothing. The USB2.0-Serial Port isnt showing up in arduino, and i can’t put anything in the port section that’ll connect it to my 3D printer

I have Mac OSX 10.13.6. I tried downloading arduino stuff for both 10.13 and 10.14. Nothing. I downloaded the drivers and all. I'm completely lost.

Even though I think this is a reasonable place to request help for using the Arduino IDE software to update the firmware on 3D printers by uploading Arduino sketches to the 3D printer board, if you are asking for support using the pronterface software, you are in the wrong place because your question doesn't have anything to do with Arduino directly.