W5100 shield not working through switch

Hi All,

I'm haveing strange probem with my ethernet shield on ATmega2560. If I connect it directly to the PC, I can ping it without any issue. I am using it as a telnet server , port 23. But when I connect it through a switch, I can't ping it nor telnet it. Switch LEDs are green so it looks like TCP layer is not working properly. Any idea what to try to set up? Both Tx/Rx are blinking so soem comm is there but honesly I have no idea what to try.. The thing is that I need to connect it to some switch to have it in network :frowning:
Any thought really appreciated.


Hi All,

So I have done some debug, it works on simple edimax switch but when I connect it to CISCO 3750 switch, it seems like arp is the issue. I tried C2950 and C3750 switches. I tried to create manual ARP entry to the IP and MAC of the arduino and I was able to connect it through C2950 but not on C3750.
Any idea how to check from sketch perspective or library perspective, if everything is fine?


Problem solved... It was the MAC address. I have to use some valid MAC to be able to connect the shield through some switch. So copy the MAC from other device and everything works now... I used SW for network analysis and it led me to ARP issue..

I try with 2 MAC and not working. My switch is TL-SF108D
With same W5100 shield think work OK. I think that problem is only with some W5100 chip.

About MAC Setting an Arduino Ethernet MAC address manually | Freetronics