Ethernet Shield W5100 connection issue

Hi. I am trying to connect a W5100 Shield to ethernet via switch. I plugged the W5100 on an Arduino Mega 2560 and loaded the web server example sketch. The problem is that when I connect it (via ethernet) directly to PC it works as expected but when I connect it through a switch it not operates. I try to cange switch with some others and I try to plug shield on another Arduino Mega 2560 and Arduino Uno also without any success. Searching in internet I found some other users experimenting the same issue but whitout any solution. Could someone help me? Thanks.

I have also experienced this problem and from the research I have done there are a number of common parameters:

  • The W5100 board is a cheap version from china
  • The resistor network immediately behind the Rj45 socket has the value 511 on it (its small get a magnifying glass - it is a black rectangle with 8 connections like a mini IC)

Basically it would appear this component is not correct. I should be 510 or close to this value. Because it is 10 times over spec it is much more sensitive to switches which are sensitive to the voltage on the network.

There are 3 possible fixes:

  • Change to a switch that is not as sensitive. There is some discussion on the board about this.
  • Change the resistor network to something close to the 49.9R that the arduino schematics suggest it should be. I have only seen one post where someone has done this and gotten it to work. This is fiddly due to the components being so small and surface mount ... you would have to be keen to do this.
  • Buy a more reputable brand wiznet board or switch to the even cheaper ENC28J60 boards which dont seem to have the same problems.

Ihope, ican help. I have 3 Ethernet Shields W5100 from China bought. 2 of them had the erroneous placement. A faulty connection occurs in particular at the when used as a Web client. The incorrect line termination is apparent in reflections that prevent the connection. I've tried everything, 4 different switches, short lines, long lines ... the result was not satisfactory. Short and sweet - my solution was quite simple: 1. Check to see if the SMD resistors are labeled 511 - see above (important) 2. Installation of two additional resistors 120 Ohm on the circuit side (Bottom Layer), immediately in connection to the Ethernet jack. One between 1-2, and the other between 3-6. The body of the resistors should point downwards so that no short circuit with the USB socket of the underlying UNO occurs. The "1" of the socket is the way to the left (shorter distance to the edge) when the Ethernet socket facing upward, of course, on the ladder page (Bottom Layer) seen.The other terminals follow slightly offset. After installation, I never had problems again ... I hope my Google English was understandable enough

Hi! I had the same problem. I've soldered two 100 Ohm resistor to 1-2 and 3-6 pins of the rj45, and it works fine! Thanks a lot!!!

I've spent a long time trawling the internet to find a fix for this, and been through a lot of links to get here (amazed it doesn't come up first on google!).

Tried the 120 Ohm resistor fix today and worked first time, @keithsw1111 you are a legend!

Great tip !!! It worked perfectly here for me too. Thank you very much

I have experienced this problem and use two 120 OHM resistors between 1&2 - 3&6

It's also work with 100 OHM ,

Thank you for sharing your experience.