Was ist falsch beim hochladen?

Moin!

Ich bin ein Neuanfänger was Arduino angeht, ich habe mir einen Nano zugelegt.

Mein Problem ist, dass ich ein Problem beim hochladen habe und nicht weiß woran es liegt.

Meine Werkzeuge sind:
Board: Arduino Nano
Prozessor: ATMega328P
Port: COM3

Mein Sketch:

void setup() {
// put your setup code here

pinMode (2,OUTPUT);
pinMode (3,OUTPUT);
pinMode (4,OUTPUT);
pinMode (5,OUTPUT);
pinMode (6,OUTPUT);
pinMode (7,OUTPUT);
}

void loop()
{
digitalWrite (2,HIGH);
digitalWrite (3,HIGH);

delay (1000);

digitalWrite (2,LOW);
digitalWrite (3,LOW);

delay (1000);

digitalWrite (4,HIGH);
digitalWrite (5,HIGH);

delay (1000);

digitalWrite (4,LOW);
digitalWrite (5,LOW);

delay (1000);

digitalWrite (6,HIGH);
digitalWrite (7,HIGH);

delay (1000);

digitalWrite (6,LOW);
digitalWrite (7,LOW);

}

Ich hoffe jemand kann mir dabei helfen, meine Ampelschaltung zum laufen zu bringen.

Bleibt gesund,
Luca

versuch mal den alten bootloader


Bitte Code-Tags verwenden

Du gibst uns zuwenig Informationen.

Hat der Upload schon mal funktioniert?
Hast Du das richtige Board und COM Port eingestellt?
Welche Fehlermeldungen bekommst Du?
Hast Du schon mal mit einen anderen USB-Kabel versucht?

Grüße Uwe

Es hat funktioniert ich denke mal dass es dies gewesen ist.

Danke für die Hilfe!

  1. Ja
  2. Ja
  3. Beim hochladen des Sketches ist ein Fehler aufgetreten.
  4. Ja

++UPDATE++

Es hat geklappt! Danke für die Hilfe!

zu 3) Ich hatte gefragt welche Fehlermeldungen Du bekommst und nicht wann.

Und was war dann der Fehler?
Grüße Uwe

Was hat geklappt? Du hast "Danke für die Hilfe" geschrieben. Ein noch besserer Dank wäre wenn du noch ein Posting schreibst in dem explizit drinsteht

Fehlermeldung die du bekommen hast
Was du gemacht hast damit das hochladen jetzt funktioniert

vgs

Wie die Antwort für mich war, wenn Sie auf das Pfeilsymbol klicken,

Sehen Sie, worauf sich OP bezog.

Diese Angabe schließt eigentlich den alten Bootloader aus.
Nur alte Arduino-Nanos, die nicht mehr im Handel sind und Chinanachbauten , die aber nicht als "Arduino NANO" bezeichnet werden sollten haben den alten Bootloader.
Grüße Uwe

Fair genug. Es könnte jedoch ein sehr alter Nano sein (aber wahrscheinlicher ein Klon).

Ich glaube nicht daß der TO vor 2 Jahren den NANO gekauft hat und erst jetzt damit anfängt.
Grüße Uwe