Website Support Email dead?

I’m trying to change my Forum Account Password. I go to my picture top right, select Profile and I get directed to a webpage and I just get a plain white page saying “Loading…”

Also the Website support email account is dead. “ failed:
550 5.1.1 The email account that you tried to reach does not exist.”

It was a bit slow to load but my profile page did load fine.

The email should be Not Did you see it written as on the website somewhere?

I have the same problem with IE, works fine via Chrome.

I'm using Firefox.

Ahh, mea culpa, I do apologise. I must have gotten a little over enthusiastic editing the webmasters email address when I copied from the website replacing the "(at)" with the @ symbol.

I'm using Internet Explorer v11 fully patched and up to date. I've tried viewing the profile in "Compatability Mode" too but with the same results.

Hi @fixit9660,
you are right, profile page doesn't work for IE11, we'll fix it as soon as possible. In the meantime you can change your password using the form at Arduino SSO - Reset Password
Thanks for your report!

Thank you. :slight_smile: