weird problem w5100 switch incompatibility

Wiznet iEthernet W5100 - (no micro sd card in it)

Tried with uno and mega, same problem with both, it works fine plugged into my netgear 10/100/1000 switches but into both my tplink and asus 10/100/1000 switches it does not work at all. You could see even on the switch the port didn’t light up, like nothing was there… odd… Even plugging the netgear into the tp-link and then the arduino into the netgear is fine, but into tp-link, no go…

Tried same cable and different cables on all three, all my other devices of various types work obviously on all three, why would the ethernet shield and arduino be picky like that??

I had the same problem . If you have ETH-shield >> SWITCH >> router or other staff you don't have connection. Without switch everything was OK. Problem is with switch. I use TL-108D. Probably root cause is auto negociacion (I'm sure that the problem is not with crose or not cable).
I changing switch for MOXA EDS-205A - everything is OK. I read that Netgar FS105 working too.