Why the TFT LCD 2.4 goes blank without the usb cable?

I'm using the TFT LCD 2.4 Shield touch screen with an arduino uno. It works fine until I tried to set it up in a device to work independently of the computer. Then it only shows a blank screen, white screen. What do I have to do to solve this problem?
THe independent system is being feed by constant 7 volts on the DC adapter.

You have to help us to help you

You might post a schematic showing all components their values, part numbers, etc. Include all power supplies and their specifications.

Without code snips it is impossible to help.

I'd think that you're screen is updated in a while loop based on serial connection

But thats just a guess

1 Like

if you have a ESP32 WROOm you might try this

  1. Please post a link to the actual Shield that you have bought.
    Make sure that the images in your link match the item on your desk.

  2. Plug the Shield into your Uno. Every male pin should fit in a corresponding female socket.

  3. Run all the library examples. Report any problems quoting example by name.

I would be much happier with a Shield running from the USB cable. If your Uno is not a genuine Arduino, please post a link to the particular clone that you are using.

Likewise, a link to your "7 volt adapter".

You might not find your actual sale receipts. But you can find most items on Ebay, Amazon, ... Just say "it looks like".

David.

THe 7 volt power source is a transformer with a diode rectifier that brings the power to a variant 12 Volts DC, then a regulator is set in place which feeds the arduino with steady 7 volts. The regulator is similar to this one https://www.donberg.co.uk/pics/t/ta_7810s.jpg Cables are soldered from the regulator to the arduino. THis is a product specially made for a Medical doctor. It works beatifully as is but only when the computer is hooked up to the arduino UNO, once I tried to leave the device on its own (without a computer), the the screen goes blank like if I had set up the wrong driver.

I think you need to understand soemthing about Arduinos.

They require Five Volts to operate. Not seven.

The clear blunder is not comprehending what the "Vin" or "RAW" terminal is. The regulator on the Arduino UNO/ Nano/ Pro Mini/ Mega2560/ Leonardo/ Pro Micro has very little heatsink, so will not pass very much current (depending on the input voltage and thus, how much voltage it has to drop) before it overheats and (hopefully reversibly) shuts down. It is essentially little more than a novelty provided in the very beginning of the Arduino project when "9V" power packs were common and this was a practical way to power a lone Arduino board for initial demonstration purposes. And even then it was limited because an unloaded 9 V transformer-rectifier-capacitor supply would generally provide over 12 V which the regulator could barely handle.

Nowadays, 5 V regulated switchmode packs are arguably the most readily available in the form of "Phone chargers" and switchmode "buck" regulators to regulate down from 12 V or other available voltages are cheap on eBay so these can be fed into the USB connector or (more appropriately) 5 V pin to provide adequate power for most applications. Unfortunately, many tutorials or "instructables" are seriously outdated or misleading and have not been updated to reflect the contemporary situation.

The shield is not the original. ITs red. I don't see a brand name

I'll tried to regulated down to 5v but yes I did read that we can feed the arduino with 7 to 12 volts. I even read that it will not work with less than 7 volts

Sorry, I can't give you more details. This is an invention for a medical device. We even modified/recoiled a transformer to be able to do what we need it to do. I just wanted to have the touch screen control the device, which it does. But not when the arduino is not conected to the computer. I had arduinos controling other devices on its own but never with a touch screen.

Thank you. I appreciate your help.

Have you solved the issue?

If the device works in one state, id be willing to bet a condition that enters, or breaks out of a while loop isn't being called correctly.

I respect the patent process, feel free to message directly if neccessary

I suggest that you plug the Shield into the Uno as Nature intended.
Power the Uno with an USB cable.

If you really, really want to use some random 12V transformer with a 7810 (10V linear regulator) we need to see how you came up with 7V. i.e. schematic, component part numbers, voltage readings, ...

More important. Where did you solder this "7 Volts" ?

God invented Shields and USB cables. If you want to be different you need to know what you are doing.

David.

Reading the wrong nonsense can be very dangerous. Especially with Covid-19! :roll_eyes:

I'll say it again, as will most others. You need a proper 5 V power supply.

To understand you have:

Computer (laptop etc) ---------[USB]---------Arduino Uno ------------ TFT LCD Shield

7 Volt adapter -------------------------------------Arduino Uno (Vin and Gnd)

Is this correct?

When you unplug the laptop etc the TFT LCD shield goes blank.

Is there any indication that the TFT shield is still getting power?
Does the Uno still have power.

Do you have any serial ports open the the USB?

My bet is that something already burned from having two power sources connected to the arduino. Now it won't work properly with a single power source.

Most unlikely. The UNO is specifically designed to select between the USB connector and "Vin" or the "barrel jack" as its power source. It will not be damaged on that account.

Something is clearly wrong, but because we really have no idea at all what you have actually done, we are not in a position to know what. :worried:

Hi @JohnRob , The source cables were soldered to the barrel conector but on the bottom part of the arduino. Positive on the center of the barrel and negative on the outside of the barrel.
The problem was solved. The system needed at least 9 volts and 1 amp to work. I was feeding in with 7 only. The system also worked with 12 volts and 2 amps but the arduino was overheating the whole time. Once the voltage was down to 9, everything worked perfectly. Thank you for your questions. I appreciate your interest on helping me.

1 Like

Hi @JBornstein90 The problem was solved. The system needed at least 9 volts and 1 amp to work. I was feeding it with 7 volts only. The system also worked with 12 volts and 2 amps but the arduino was overheating the whole time. Once the voltage was down to 9, everything worked perfectly. Thank you. I appreciate your help

1 Like