WiFi101 Firmware Update does not work with IDE 1.8.13, but with 1.8.5

Hi all,

I have an Arduino Mega 2560, and a WiFi101-shield. Today i wanted to update certificates to the WiFiShield with the Firmware Updater, but I could not get it running with arduino IDE 1.8.13 - I always get an error message "Programmer not responding" (Yes, I downloaded the sketch to the board, and that worked fine)

I tried to follow How to update the WiFi Nina and WiFi101 firmware, which was not possible, because the programmer could not connect.

The CheckWifi101FirmwareVersion worked:

WiFi101 firmware check.

WiFi101 shield: DETECTED
Firmware version installed: 19.5.4
Latest firmware version available : 19.6.1

Check result: NOT PASSED
 - The firmware version on the shield do not match the
   version required by the library, you may experience
   issues or failures.

Of course I could not update the firmware without connection to the programmer :frowning:

As I knew this worked on my old PC, I tried an old version of the Arduino IDE. 1.8.10 did not work as well, but 1.8.5 worked - I could update the certificates :slight_smile:

Still, with 1.8.5 I cannot update the firmware, because the newer version is not available in the firmware updater.

Even if its working now, I would like to use up2date-versions.

Any ideas?

Any help would be appreciated,
Thanks & Regards,
Klaus