How to connect WiFi 101 shield to Arduino Uno?

My WiFi 101 shield isn't connecting to the Uno. When I run the example sketches WiFi.status() == WL_NO_SHIELD is always true.

Are you using the WiFi101 library?

Hi Pert,

Yes, I’m using the WiFi101 library. I updated my Arduino IDE software as prior to that I was getting a compile error due to an issue with the 101 library. Now, when I upload one of the example sketches to scan for networks, or try any other sketch using the WiFi 101 shield, it always says the WiFi shield cannot be found.

I’ve found older posts online about the issue saying I need to update the shield’s firmware, but I can’t see how to do that, as I don’t see a way to connect to the wifi 101 shield directly from my computer; there is no usb on it.

Jon

The product description (https://www.arduino.cc/en/Main/ArduinoWiFiShield101) says:

The WiFi Shield 101 needs certificates to ensure SSL connection. To update new certificates you need this tool:

https://github.com/arduino-libraries/WiFi101-FirmwareUpdater/releases

Hi John, Thanks for your message. I'm not using SSL though, surely that would only be an issue if I try to make an https request? Also, how does one update the firmware on the WiFi 101 board, as there is no way to connect directly to it?

JonHudson: Also, how does one update the firmware on the WiFi 101 board, as there is no way to connect directly to it?

I imagine that question would be answered in the documentation for WiFi101-FirmwareUpdater.

OK I've just followed the instructions in the WiFi101-FirmwareUpdater (thank you for informing me of that, I somehow missed that page). The command line output was:

2016/05/31 22:36:21 Connecting to programmer 2016/05/31 22:36:24 Synch with programmer 2016/05/31 22:36:24 Reading max payload size 2016/05/31 22:36:24 Flashing firmware from 'firmware/19.4.4/m2m_aio_2b0.bin' 2016/05/31 22:36:24 Error during FlashErase()

And now when I try to upload one of the example sketches, such as "ScanNetworks", it still just prints "WiFi Shield not Present"

Sounds like your shield is defective or is not mounted on the UNO properly. Unmount it and check all the pins to make sure none are bent. Then make sure the pins are all aligned properly when you plug the shield in. The six ICSP pins should go into the six sockets on the bottom of the shield.

It appears to be mounted correctly, all pins are in place. Still no joy. I'll try to get a replacement from the store. Failing that I guess it could also be an issue with my Uno board. Thanks for your help!