Win10 trouble with Uno and USG

Hi there - I think I'm in the right forum, apologies if not.

The short story is that I've been using an Uno for years as the brains behind my CNC machine, on Win7. Its been working brilliantly. However, I've just upgraded the laptop to Win 10 regretting it big time...

I've been reading quite a few posts on various forums, trawling the internet, watching videos etc. Lots of people seem to have had similar issues, but none of the advice I've found is addressing my problem. I'm a bit lost frankly...

The first issue was Win10 showed the Uno as USB2.0 Serial in device manager.

I tried a few things here, trying to manually install Arduino drivers (with no joy) and eventually googling the Hardware Ids and installing some CH340 drivers.

This gave me a Comm Port and I can see the UNO in the Arduino IDE. Progress?:

However, when I fire up USG there doesn't seem to be much in the way of communication. The software appears to be connected, on the correct port, but the machine is offline:

I also tried this on an older version of USG, a backup of what I was using on Win7. The machine doesn't connect and hangs on 'INFO: Getting gcodefile." which I've been lead to believe means its not receiving grbl from the arduino.

Anyway, I'm at a complete loss and would really appreciate any help or pointers people can give me.

I'm fairly tech savvy and managed to find my though the initial installation several years back, so I know this isn't beyond me. I'm tempted to start from scratch now, but slightly worried I'm building on sand with Win10 and/or the laptop I have.

I'm hoping I'm doing something glaringly wrong and somebody here can help me.

Thanks in advance! :crossed_fingers: :crossed_fingers: :crossed_fingers:

Just to be certain, I would check that COM5 is really the port of your Uno derivative board. The computer may have other serial ports unrelated to the Arduino board. You can do that via the Arduino IDE by following these instructions:

  1. Unplug your Arduino board from the computer.
  2. Select Tools > Port from the Arduino IDE's menus.
  3. Note the ports, if any, listed in the menu.
  4. Close the Tools menu. The ports list is only updated when the Tools menu is re-opened, so this step is essential.
  5. Plug your Arduino board into the computer.
  6. Select Tools > Port from the Arduino IDE's menus. - The new port listed in the menu is your Arduino board.

Thanks for your reply @in0

I'm pretty damned sure we're on Com5 here, that's what pops up in Device Manager when i connect the board and that's what IDE is telling me:

If you have any other ideas, or anybody else does, that'd be greatly appreciated.

Thanks in advance.

I think you are right. It is a common problem and very easy to check, so I thought it was worth a look.

Unfortunately, I don't know much about the CNC subject. Would it be possible for you to manually send some basic G-code commands via that "Command" field in UGS to see if the Uno responds to them?

Fixed it!

Seems Windows 10 didn't like my Uno clone (that I'd been using on Windows 7 for years..), I replaced it with an original board and its up and running again.

I'm glad to hear you found a solution. Thanks for taking the time to post an update.

Even though it seems to be of questionable functionality, you might hold on to that derivative board in case you ever feel like doing some general experimentation with Arduino. Even though those derivative boards that use the CH340 USB chip can be a pain to get set up, most people eventually manage to have success with them for general tinkering with electronics (evidently the situation is not so nice with UGS).

A spare Arduino board can also be a really nice tool to have on hand because you can easily convert it into an ISP programmer for burning the bootloader or flashing a sketch to another Arduino board. Sometimes that can allow you to recover Arduino boards that have somehow become "bricked".

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.