Windows 7 fails to install drivers - not even listed in Device Manager

Hi spent over a day on this, so much appreciate some help please.

First, having failed to get my Nano Every working with Windows 7 I tried a Linux laptop and managed to get it to work. So the Nano Every and the USB cable are fine.

On Windows 7 Professional 64bit EUS I have tried to install both the Web based Agent and the full IDE. In spite of giving the OK to install numerous drivers [I noticed that each one creates a System Restore point, thus wiping out my previous SR points :frowning: ] there are no new COM ports. All I have is the standard COM1 with a MS driver dated 2006!

Note: After an initial failure due to Sophos deleting the drivers I disabled Sophos.

So, with the Agent install I accepted all the prompts to install drivers:

  • Auduino [didn't note full name but think it was a USB driver], libusb-win32, Genuino USB, Intel Corp Ports (COM & LPT), libusb 1.0, Ports (COM & LPT) + Windows prompts x2 re unsigned drivers

With the full IDE the drivers were:

  • Adafruit Industries LLC Ports (COM & LPT...) , Arduino USB Driver Linino Ports (COM & LPT)

All Device managers shows is:

I've selected "Show hidden devices" and I've expanded most sections and seen nothing reflecting these new drivers.

If I plug in the cable then Windows tries to install a Arduino Nano Every under Other Devices with a yellow not working flag. I had that problem with a Pico and I believe this is Windows seeing it as a USB storage device, which on the Pico is used to write the firmware but not any user code.

I would really like to get it working on Windows as this is a desktop installation with a big wide screen and an ergonomic keyboard and good physical setup. The laptop is clunky by comparison. Plus I keep all my development notes on the desktop.

Thanks for reading.
PS All I want to do is count pulses on 3 digital input pins and then on request send the totals to a Rasp Pi, using I2C or SPI but not UART and using Python (not C). With the Pico it transpires that there is no support for Micropython as a peripheral (slave). I've seen Audiuno Sketch code that does this with I2C in about 8 lines using Wiring. I hope this is my salvation!

Start here:

There are links in it.

Hi. Thanks for replying. I've already tried all the suggestions in the other posts were relevant. Just to be sure, here's my Nano Every. Not a clone as far as I can tell:

I had similar issues with my Pico and when I got it working with a 3rd party driver it appeared in my Device Manager under Ports (COM & LPT) as COM24 "Pi Pico Serial Port". I.e a higher port number.

With the Pico it transpired that there was no driver support for Windows 7, hence the 3rd party driver (actually a INF configuration file). Re the Arduino Agent/IDE the website does say the software supports Windows 7 (unless it's an old statement and the driver has been updated to Windows 10 only).

As I said in my 1st post, I said yes to Windows about 6 or more times for different drivers yet my Device Manager is unchanged!


The EVERY is supported in win 7.
Or at least it was when I got mine.
Took the liberty of moving you to the correct section too :wink:

If you use the extended search of the forum for "drivers" you will find that most problems are down to a very few things.

Lack of permissions (not your own computer)
Driver enforcement
USB 3.x

We also have SPECIFIC sections for your NANO where the topic is also covered

You can also use the official support channel but please also reference this post URL.

Some additional general advice below.

Could you take a few moments to Learn How To Use The Forum.
It will help you get the best out of the forum in the future.

  • Your OS and version can be valuable information, please include it along with extra security you are using.
  • Always list the version of the IDE you are using and the board version if applicable.
  • Use quote or add error messages as an attachment NOT a picture.
  • How to insert an image into your post. ( Thanks @Robin2 )
  • Add your sketch where applicable but please use CODE TAGS ( </> )
  • Add a SCHEMATIC were needed even if it is hand drawn
  • Add working links to any specific hardware as needed (NOT links to similar items)
  • Remember that the people trying to help cannot see your problem so give as much information as you can


  • Ensure you have FULLY inserted the USB cables.
  • Check you have a COMMON GROUND where required. ( Thanks @Perry)
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check or remove your wiring first.
  • Remove any items connected to pins 0 and 1.


  • Close any other serial programs before opening the IDE.
  • Ensure you turn off any additional security / antivirus just to test.
  • There may be a problem with the PC try RESTARTING it.
  • You may be selecting the wrong COM port.
  • Avoid cloud/network based installations where possible OR ensure your Network/Cloud software is RUNNING.
  • Clear your browsers CACHE.
  • Close the IDE before using any other serial programs.
  • Preferably install IDE’s as ADMINISTRATOR or your OS equivalent


  • CH340/341 based clones do not report useful information to the “get board info” button.
  • NANO (Old Types) some require you to use the OLD BOOTLOADER option.
  • NANO (ALL Types) See the specific sections lower in the forum.
  • NANO (NEW Types) Install your board CORE’s.
  • Unless using EXTERNAL PROGRAMMERS please leave the IDE selection at default “AVRISP mkII”.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

CREATE editor install locations.

  • On macOs ~/Applications/ArduinoCreateAgent-1.1/
  • On Linux ~/ArduinoCreateAgent-1.1/config.ini
  • On Windows C:\Users[your user]\AppData\Roaming\ArduinoCreateAgent-1.1

Performing the above actions may help resolve your problem without further help.
Language problem ?
Try a language closer to your native language:

Thanks to all those who helped and added to this list.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.