Yun not showing up via USB

I have been having fun with my new Yun, but its not showing up via USB on my Mac's (OSX 10.8.5 and 10.9). It does not show up as a keyboard also like the instructions say it might. My Uno R3 shows up no problem. I have been doing everything over the network to it since that is the only way it works. That is fine using ssh for the console but it would be nice to also use Serial with the Mac also so I don't have to change out all of the Serial connections to Console connections when testing older scripts.

I looked at the Mac System Information app and I don't see the Yun on the USB bus. Does the Yun need a special driver (I have the driver for the Uno R3 as FTTI drivers from other projects). Nothing on the getting started page said anything about that.

I just tried it under windows also and it only shows the network port for connecting to the Yun. I am running 1.5.4 of the Arduino software. I have verified that the USB host port works but since that is on the linux side of things that does not say the program micro usb port is working.

So no one has seen this problem and you all are showing a local serial port for the Yun when connected to the micro usb port?

I am worried I have a bad board.

I found the issue. It was a bad usb cable that worked for charging but not data. I had thought I had tried two different cables but I guess I had only used the other cable with a usb battery.... oh well.

Thank you for this! I was hitting my head on the wall trying to figure out why I couldn't see my Arduino Yun in the port menu. New cable that supported data was it. Thanks.

This needs more visibility. I spent a day and a half going through all the FTDI driver installation instructions backwards and forwards only to find out I was using a charging only USB cable? That's a thing!?

Thanks Driften

That’s a thing!?

Yep, that’s a thing.

Lots of devices these day use a micro USB cable as a charging port. They include a small charging device and a cable. Copper is expensive, so why include a couple wires in the cable that are never used by their product? By eliminating the data wires, the overall cable is slimmer (appealing to the customers) and less expensive (appealing to the manufacturer’s accountants.)


Can you change the subject, and pre-pend to the subject [SOLVED] ?

TIA Jesse

I have the same symptoms, but my USB cable is a certified USB 2.0 four conductor data cable.

I have been using the Arduino Uno for a few years. I just got this Yun and updated the firmware. It connects to my WiFi and by Ethernet cable. Both of these show up in the IDE under Tools/Port/Network Ports. But nothing shows up for the USB Serial COM ports. So most of the example programs won't connect. I get the ever popular "Unable to connect: is the sketch using the bridge?" running WiFiStatus.ino.

I have even tried an external terminal emulator on COM 1 to 10 but nothing comes through.

SherpaDoug: I get the ever popular "Unable to connect: is the sketch using the bridge?" running WiFiStatus.ino.

The error you get happens when you select the network port under Tools/Port/ and open Serial Monitor but the sketch does not use the Console provided by the Bridge.

The WifiStatus sketch uses the Serial over USB cable, so after you upload the sketch, you have to select the COM port in the IDE and then open the Serial monitor.

With no Arduino attached running the IDE shows com1,2,3 at Tools/Ports. Plugging in the Yun by USB cable and giving it a few minutes to boot adds 1 or 2 entries at Tools/Ports/Network Ports depending on if I have the Ethernet in addition to WiFi. But it does not add any new COM port options. The old Com ports 1, 2, 3 do not seem to do anything here.

SherpaDoug: But it does not add any new COM port options.

Some possible reasons: (not in any particular order)

  • The bootloader is corrupted or the wrong bootloader is programmed. Loading a sketch over the network should fix this.
  • The cable is bad, try a different cable. (Certifications mean nothing if a contact is bad or a wire is broken.)
  • The USB connector on the Yun is damaged.
  • The USB connector on the computer is damaged, try another port.
  • The USB driver on the computer is corrupted or not installed, try removing the existing driver(s) and reinstalling.

After getting away from it for a day, marching in a Memorial Day parade, a night's rest, but no intentional hardware or software changes, now it just works! Maybe it feeds on patriotic fervor?

The debug tips will be good for the next guy with this problem. I just hope it is not me tomorrow.

Arise old thread...

I just wanted to say that after wrestling with my Yun for a good 12 hours or so (and convincing myself it was broken) I was finally able to solve the problem thanks to this thread. After all of that... IT WAS THE CABLE!!!!!

I had no idea that all micro usb cables were not created with charge and data capabilities. Makes sense now though. Man...

Hopefully my carefully added search terms will help some other poor guy...

Lubuntu 12.04 no /dev/ACM arduino yun is not seen ubuntu yun not recognized port grayed out lsusb no arduino dmesg shows nothing after connecting yun yun not seen

In short, make sure your cable is data capable! Mine apparently was not.

FWIW, my cable has: "usb 2.0 double shielded high speed cable 80* C 30V 28AWG/1PR and 28AWG/2C Micro Connectors, Inc." printed on it.

Why don't they cram a suitable cable in the Yun's box? It would cost, what, $2 more?

That's 12 hours I'll never get back.

Power-only cables are distressingly common in some devices. The manufacturer can save a few cents per unit by not including the relatively expensive copper conductors, or can save a few cents per unit by not expending the labor to solder the wires in place. Multiply that few cents per unit by the thousands or millions of units built, and even a little savings can add up to real money.

aaronzillion: Why don't they cram a suitable cable in the Yun's box? It would cost, what, $2 more?

Unfortunately, that probably won't prevent the problem in the long run.

I'll bet I'm fairly typical in that I have a pile of USB cables for various devices, and I don't permanently marry a cable with a device. Once I'm done with a device for a while, it goes into storage with other devices of the same type, and the cable goes in a drawer, mixed in with other cables. If there is a power only cable in the mix, it's likely to be pulled out the next time the device (not necessarily a Yun) is used, and the problem happens all over again.

My typical mode of operation is to grab any old cable and plug it in. If it doesn't work, unplug it and plug it in again. If it still doesn't work, try a different cable - if the new cable works, the old cable goes straight in the trash! Cables are so cheap and prevalent that it's not worth trying to debug why the cable didn't work: I don't care whether it's a bad contact, broken wire, or power-only cable - it's gone!