12V LED mit Arduino schalten

Hallo,

Ich versuche momentan eine 12V 3W LED Lampe mit dem Arduino zu schalten. Dazu habe ich ein Transistor BD135 und ein Widerstand von 900 Ohm.
Den Ermitter habe ich auf GND gesetzt. Den Collector habe ich mit der LED Lampe und von der LED Lampe mit 5V verbunden. Die Basis ist über ein Widerstand (900Ohm) mit dem PIN 13 des Arduinos verbunden.

Habe ich an der Schaltung etwas falsch gemacht, denn die Lampe leuchtet nicht auf. Über jede Hilfe wäre ich sehr dankbar!

a) mach ein Schaltbild und stelle es hier ein, deine Erklärung zu 12V und 5V ist nicht ausreichend.
b) mach eine Echtbild und stelle es hier ein
c) beachte, dass der Transe ECB ist
d) this is not the German section of the arduino board!!!

Bei dem Transistor im Bild sind die Pins wie folgt: 1.Pin: Collector, 2. Pin: Base, 3. Pin: Emitter.

Bei der LED Lampe handelt es sich um eine 12V 3W.
Da der Arduino nur 5V ausliefern kann, habe ich hier mit einem Transistor gearbeitet, dem BD135.

Eine Fehlermeldung gibt es nicht.

Dass es sich um ECB handelt, habe ich beachtet.

Im Programm setze ich den LED auf HIGH. Mehr mache ich mit dem LED nicht. Das heißt, nach der Übertragung des Programmes auf den Arduino, sollte die LED aufleuchten. Das tut sie aber nicht.

Was genau mache ich hier falsch?

Es tut mir leid, ich wusste nicht, dass es sich hier nicht ums englische Forum handelt.

on english:

The pins of the transistor in the picture are as follows: 1st pin: Collector, 2nd pin: Base, 3rd pin: Emitter.

The LED lamp is a 12V 3W.
Since the Arduino can only deliver 5V, I used a transistor, the BD135.

There is no error message.

I noticed that it is ECB.

In the program I set the LED to HIGH. I don’t do more with the LED. That means, after the transfer of the program to the Arduino, the LED should light up. But it doesn’t.

What exactly am I doing wrong here?

I’m sorry, I didn’t know that this is not an english forum.

Translated with www.DeepL.com/Translator

du mußt die LED schon an 12V ankemmen

Eine 12V LED Lampe leuchtet kein bißchen mit 5V. Du brauchst eine 12V Versorgung.
Die Masse der 12V und GND des Arduino müssen verbunden sein.


Die USB Bzw der Arduino bringt nicht genug Leistung um 2 Servo ansteuern zu können. Du braucht noch eine Spannungsversorgung für die Servos.
Pin 13 ist keine glückliche Wahl für den IR Sensor (rate ich mal). Nimm ein anderes Pin.

Grüße Uwe

Also bräuchte man ein 12V Netzteil?

Ja, nur mit 12 Volt wird die Led sicher leuchten. Naja evtl. reichen zum Leuchten auch schon 9 Volt.
Aber bei 12 Volt bist du auf der sicheren Seite und die Leds leuchten auch hell.

sergio934435:
Also bräuchte man ein 12V Netzteil?

Ja. Du könntest mit dem richtigen 12 V-Netzteil sowohl den Arduino (über Vin) als auch die Lampe betreiben.

Gruß

Gregor

Ich habe noch eine blöde Frage: kann ich ein Netzteil benutzen was als Output 12V 3,33A aber ein Input von 200-240V?

Das liest sich nach einem alten Netzteil, vermute das ist nicht geregelt.
Hast du ein Foto vom Typenschild ?

Anbei Typenschild

sergio934435:
Anbei Typenschild

Wo ?

Leider kann ich es nicht hochladen. Welche Information bräuchte man denn?

sergio934435:
Leider kann ich es nicht hochladen. Welche Information bräuchte man denn?

Hast du ein Foto gemacht ?
Wie groß ist das ?

Bzw. Könnte ich das Netzteil vom Ladegerät meines Handys benutzen (iPhone)?

sergio934435:
Bzw. Könnte ich das Netzteil vom Ladegerät meines Handys benutzen (iPhone)?

Eher nicht.
Das hat sicher auch nur 5 Volt.

Das Bild aus #14:

uxomm:
Das Bild aus #14:

Ist das mit diesem Netzteil kompatibel?

sergio934435:
Ist das mit diesem Netzteil kompatibel?

Ja, ok, das Netzteil ist geeignet.
Damit kannst du deine Leds betreiben.

Vielen Dank an alle, die mir hier so herzlich geholfen haben. Super Community hier.

Übrigens es funktioniert alles!:slight_smile: