5-12V DC pump doesn't start through relay

Hello everyone, I’m making automated watering system.
I’m using 5-12v relay, to control pump.
Issue is that, the pumps doesn’t work when connected to relay. I can hear how relay switches, but pump doesn’t work. When i connectdirect to 12v, pump starts working . Shematic what i’m using.


And how its looks in real life. Lcd screen is for data output.

I can’t see a 12 V DC supply there, but somehow the battery out of your smoke alarm seems to have been mislaid amongst your Arduino kit. :roll_eyes:

I suggest you put it back in the smoke alarm where it belongs. :rofl:

Could you add to that diagram to show how the pump is powered? The circuit looks OK so far, but without seeing the rest of it, it’s hard to tell where the problem is.

Everything looks good. But your real time circuit is clumsy to see. Just look into it. Please ensure your wiring is done properly. Your arduino pins are connected properly. Your battery is connect properly and check the voltage of your battery. Moreover look into the code, if any logically incorrect statement might be done. Look into these things and give a try once

haha, also was experimenting with batteries :smiley:
Here is 12v connect

Sounds like a wiring issue. Grab your meter and see what’s happening on the relay switched contacts.

Sorry, can’t see anything useful from the photo. I meant extending the circuit diagram (schematic) to include the pump and 12V power.

the first question is if the relay is 12V or 5V and if you have the correct power.
you will know by the printing on the relay itself. it says 5V, so I assume you are powering with the black power wires at 5V? [ op’s that is only for the pump ]

next is where the 5V is coming from ? the Arduino board does not provide enough power out to drive relays reliably.

second is if the relay clicks when you signal it to activate ?

if those are both correct and then it is wiring for the pump.

as a suggestion, some painters tape on the wires to hold on the desk. they could hold them in isolation so they don’t cross over each other to make it so hard to see. you can write on the tape to help.

Relay is 5V, i power relay from arduino, i have tried to power it from different power source (5v), but then it doesn’t work.
When its powered from arduino, it have click sound when its activated.
Made shematic ac simple as posible

if the relay clicks from the signal of the Arudino , and the indicator LED lights on the relay module, then that part is good.

the latest picture looks like the relay common connects to the ground (blue) wire / rail for the power supply.

the pump wire (unseen) connects to the NO screw

the motor red is connected directly to the 12v rail on the bread board.

if the relay is working, then it should run the pump.

tie your 5v and 9v gnd together.

Didn’t work

All correct, but pump still doesn’t work

put led “IN1” to see if you are ON or OFF

just studied your circuirt more.

there is a diode, and a transisotor on the board. I trust they are not used for the relay ?

The relay module only requires 5V to the power input and ground.

the arduino pin goes directly to the control pin on the relay module.
in the schematic in an early post, shows what exists on the relay module.

Hello
the next step: check the funktionality of the relais by using a ohmmeter.
Post a picture of the relais from both sides in detail.

take a jumper and connect from the ground rail to the relay screw holding the pump wire. that would bypass everything and show the pump runs on power.

I would suggest you move the relay wires to 3 rows on the board.
connect power to power
connect ground to ground
connect a 1k relay to the arduino pin that is controlling it.

no additional diode or transistor

give us the number on your transistor

I took down transistor, diode and resistor, still nothing.
Now shematic looks like that

2n2222a