Aduino as ISP: programmer not responding

Trying to use Arduino-as-ISP for programming a MINI PRO clone with a NANO clone.
Setup is exactly as described in the ArduinoISP tutorial with USE_OLD_STYLE_WIRING enabled.
The NANO (programmer ) have the 10uF reset override capacitor.
The programmer is running with heartbeat LED OK.
When I use this setup to program a modified BLINK sketch I get the screenshot below :

With exactly the same setup I am able to burn the bootloader to the MINI PRO. So the serial port on my labtop is OK.
And the newly installed bootloader WILL work with a serial to USB converter.

Configuration:
Windows 10 labtop.
Arduinio IDE 1.18.3 freshly installed.
NANO: Clone marked "LISA 2011" with "old bootloader".

MINI PRO: Clone marked: freeduino Pro v1.2 and two other pieces marked MINI PRO
The description above holds for all three devices.

Any ideas as to how the ArduinoiISP CAN burn a bootloader to the MINI PRO, but NOT upload the sketch?
And any ideas how to solve the problem?
Thanks.

How certain are you that you have burnt the bootloader? Don't the clone boards come with bootloader?

Yes they had a bootloader before.
But the fact is that the “burn bootloader” command actually ran to an end with proper signaling from the “ArduinoISP LEDs” and with a proper end message.
On the contrary, any attempt to upload a sketch gives the “programmer not corresponding” message. And red error LED.

Could you try using bit banging on pins other than the nano spi pins? I usually use pins 3 5 6 7. Pin 4 would be sad card cs.

Bit banging is slower so is more likely to work.

Thank You for your suggestions.
I tried your approach. Made changes to ArduinoISP as shown below.
The result was the very same. Burn bootloader worked. But upload failed with the same response:
avrdude: stk500_recv(): programmer is not responding.

So, I am no closer.
Question: Could "Burn bootloader" and "Upload" work with different baudrates??
It seems that Arduino ISP is expecting BAUDRATE = 19200.
Line 142 in ArduinoISP:
// Configure the baud rate:

#define BAUDRATE 19200

Question: Could "Burn bootloader" and "Upload" work with different baudrates??

Just to verify. You are using Sketch/Upload using Programmer, instead of just Upload?

kprims: Thank you! for pointing me in the right direction.

Your question solved the problem. I was using the ordinary "upload" .

This solved the problem. At least when I use "Old_style wiring"
When I used the ICSP connector the programmer came up with a wrong processor ID .

However I will not go further into this. I just mention it in case others should have the same problems.

I would have been helped a lot by the ArduinoISP tutorial if it had a section:
**Uploading sketches with ArduinoISP. **
With the proper instructions to use "Upload Using Programmer".

But for now I am happy to be able to start sketches without the 1.5sec delay.

Also thanks to liuzengqiang for taking the time to direct me through troubleshooting.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.