APC220 connection problem

Hello,
I’m having a problem with connecting two apc220 modules. Tried to solve the problem for the past few days but no luck. one is connected on arduino nano, the other on PC over USB-TTL module(com port 4). If anyone has a clue what is going on and how to solve it, I would appreciate it :smiley:
For starters, two standard apc220 modules set by steps and settings written on this web page:
http://wiki.openpilot.org/display/Doc/APC220+Transceiver+Telemetry
RF frequency: 434
RF TRx rate 19200
RF Power: 9
Series rate: 57600
NetID and NodeID are the same on both modules

After that, I ran simple sketch to test the connection:

#include <SoftwareSerial.h>
#define txPin 11
#define rxPin 10 //not actually used
SoftwareSerial mySerial(rxPin, txPin);

void setup(){ 
  pinMode(12,OUTPUT); 
  digitalWrite(12,HIGH); //APC220 SET pin

  Serial.begin(115200);
  Serial.write("Start");  //this is for the connection to the PC
  mySerial.begin(57600);   //this is for the Arduino to talk to the APC module
  mySerial.write("Start");
}

void loop(){ 
  if(Serial.available() > 0){    //If a character is sent to the Serial port
   mySerial.write(Serial.read());   //send that character to the APC220 serial port
  } 
}

I noticed that when I try to send anything on mySerial, arduino doesn’t send it (TX LED doesn’t blink). Also, I connected + and EN pin together on apc connected to arduino, but nothing happened.

Thanks for reply,
antisha

Anyone? :~