arduino as isp sucks(in my case)

I tried to use arduino as isp. i connected everything correctly and upload the sketch. i pressed the burn burnloader button. after 30 seconds i get error and my microcontroller break. now it's not working. i tried it again and i break another microcontroller.can anybody help me? did it happend to you? BTW while burning led was blinking very fast with low light.

i connected everything correctly

9 times out of 10 that turns out to be not the case.

Check all your connections very very very carefully.

i tried everything with multimeter connected to leg of microcontroller and it was fine. this is error i get while uploadnig avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64 avrdude: stk500_cmd(): programmer is out of sync

How about some good pictures of your setup. Make sure that we can traces your wires.

It would be very useful to know how you connected everything up - how were the various devices powered, for example. Can you post a picture of your setup?

Most commonly it is an issue like not disabling the auto-reset on the Arduino that causes the failure. However that shouldn't fry your target controller. ATMegas are hard as nails and I would be surprised if you had actually killed it. You can render them unresponsive with bad fuse settings but even that should be realtively difficult while uploading the bootloader.

Are you sure that you selected the correct bootloader for your target controller before you hit the upload button? If you are using an Uno to load the bootloader to a stand-alone '328 then you need to select the correct board or the serial port on the new chip will not work (it will be expecting to communicate with the other ATMega on the Uno board). Similarly, if you uploaded a bootloader that sets fuses for an external crystal and don't have one then the chip would look like it was unresponsive. More details of your setup might allow someone to help you.

thanks guys for fast replies. i realized that my microcontroller is still working XD. i think that problem is in arduino because i dont have one. i'm using atmega328 that's already bootloaded http://www.rlx.sk/product.php?id_product=556.im using ic max232 and serial port for communication.BTW im sure that i selected the right target microcontroler because both of them are atmega328.

Have you successfully uploaded the ArduinoISP sketch to the master '328?

yes.

I really think there's most likely to be an error with your setup. Any chance of a picture?

I assume the chip with the bootloader is running OK, has a crystal & caps attached, and is loading the Arduino ISP sketch OK. Have you also used a couple of decoupling caps on that one? Unstable power might cause you problems.

Shouldn't be any issues with auto-reset. Do you see the heartbeat from the Arduino ISP sketch?

Have you really connected pins 16, 17 & 18 of the two '328s to each other? Have you connected pin 15 of the bootloaded one to pin 1 of the target one? Do both have pull-ups on their reset pins? Does the target chip actually have power? I've managed to do all of those things wrong at least once!

ok so here are some images. its powered with adapter 9v and stabilized with stabilizator. in cover of rs232 is max232 and some resistros and caps, its working because i can upload sketches with it. there are some extra wires that are not connected

by the way can i upload images from pc?

I think you have to host them somewhere like image shack: http://imageshack.us/

here they are:
http://imageshack.us/photo/my-images/208/24052012758.jpg/
http://imageshack.us/photo/my-images/823/24052012757.jpg/
http://imageshack.us/photo/my-images/267/24052012756.jpg/
http://imageshack.us/photo/my-images/205/24052012755.jpg/

24052012755.jpg

24052012756.jpg

24052012757.jpg

24052012758.jpg

Have you tried with power to pin 20 of your target?

Also, what does the RS232 converter do with regard to auto-reset? Once you have uploaded the ISP sketch, I might try unplugging the 232 converter from reset and pulling pin 1 up with the normal 10K just in case it is resetting half way through.

pin 20 is connected but it’s not seen on picture. i tried to connected only rx and tx but no results. the same error. any other idea?

miros: avrdude: stk500_paged_write(): (a) protocol error, expect=0x14, resp=0x64

Using Arduino IDE version 1.0? Have you patched the ArduinoISP sketch?

yeah i have arduino 1.0 and what's that patch?

http://lmgtfy.com/?q=arduinoisp+does+not+work+patch+site%3Aarduino.cc%2Fforum

…first hit…

thanks but i already find(im not that lazy). and its still burning. there is written tis may take a minute but it's more than 10 minutes so i don't know.

Dr_Ugi: I think you have to host them somewhere like image shack

Two things...

  1. Please do not use nor recommend ImageShack. While trying to view miros' images, I was presented with three scams (e.g. your computer is infected with a virus).

  2. Any file, including images, can be attached to a post by clicking [u]Additional Options[/u].