Arduino Due über VIN versorgen -> PC schmiert ab!

Guten Tag,

da ich jetzt schon den zweiten Tag am selben Problem sitze und es nicht gelöst bekomme, benötige ich nun eure Hilfe.

Und zwar betreibe ich meinen Arduino Due mit einer externen Spannungsversorgung von 12V und steuere ihn dann im External Mode über MATLAB / Simulink. Das heißt, ich habe die externe Spannungsversorgung UND ein USB Kabel am Programming Port angeschlossen, welches mit dem PC verbunden ist. Das ist allerdings kein Problem für den Due, da dieser mittels eines Transistors automatisch zwischen den Versorgungen umschaltet.

Nun zum Problem:

  1. Schließe ich nur die 12V Spannungsversorgung am VIN Pin an und messe dann am 5V Pin die Spannung, liegen dort 7,2V an.

  2. Sobald ich nur das USB-Kabel am Due angeschlossen habe, stimmt die Spannung am 5V Pin (logischerweise), aber ich kann am VIN Pin ein Spannung von 4,3V messen.

-> Wenn ich erst die externe Spannungsversorgung anschließe und dann das USB-Kabel, schmiert immer mein PC ab. Ich denke dieser bemerkt, dass Überspannung anliegt und sagt dann "Und Tschüss!".

Kann mir einer von euch erklären, was an der ganzen Sache der Haken ist?

Laut Schaltplan dürfte Fall 1. und 2. doch gar nicht eintreten oder? Denn wenn lediglich das USB-Kabel angeschlossen ist, kann normalerweise nirgends eine Spannung auf den VIN Pin zurück gespeist werden (außer evtl durch den 5V Spannungswandler MPM3610?). Und falls nur die externe 12V Spannungsversorgung angeschlossen ist, dürfte der Regler die Spannung am 5V Pin doch auch perfekt auf 5V regeln.

Ich hoffe ihr könnt mir weiter helfen!
Vielen Dank schon mal.

Vor ein paar Monaten habe ich einen Fall gesehen, in dem der Spannungsregler an der DUE nicht richtig funktioniert hat. Wenn dies der Fall ist, bitten Sie den Verkäufer um Erstattung.

Schalte mal bei der Messung ein 10kOhm Widerstand paralell zum Meßgerät.
Grüße Uwe