Arduino Nano 33 BLE Sense Driver Problem.

Hello all!

I was just getting started and wiring my first Nano project. I cannot upload my project and the only error I get is this...

avrdude: ser_open(): can't open device "\\.\COM7": The system cannot find the file specified.


Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Upon further research, I found this is most likely a Driver issue, and I can't find the official Arduino driver for it or how to install it correctly, so I will need some help :slight_smile: !!!

Thanks to all that can help!

Moved your topic to it's current location / section as it is more suitable.

Please read the sticky posts at the top of this section as they have important information for the newer NANO series.

Could you take a few moments to Learn How To Use The Forum.
Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Hello DereKoder,

Are you using the Nano BLE board (instead of the old Nano board) when you are uploading the code?

The board packages used for this can be installed through Tools -> Board -> Board Manager -> Arduino nRF528x Board (Mbed OS).

Also, I would double-check that when you plug in the board the orange/yellow light isn't pulsing and that you have a USB cable that allows data transmission instead of just power.

Hope that helps,
Matt

@derek

Your log

avrdude: ser_open(): can't open device "\\.\COM7": The system cannot find the file specified.


Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

shows that avrdude has a problem. Since the Nano Sense is mbed, check that you have selected the correct board Arduino nRF528x Board (Mbed OS). mbed uses bossac to do the programming.

@matt_lee_smith ,

matt_lee_smith:
The board packages used for this can be installed through Tools -> Board -> Board Manager -> Arduino nRF528x Board (Mbed OS).

Ok! I got this done!

matt_lee_smith:
Also, I would double-check that when you plug in the board the orange/yellow light isn't pulsing and that you have a USB cable that allows data transmission instead of just power.

Is there a common cable I might have in my household that I can use? Or any proper indicators? Otherwise, can you point me in the right direction to one online?

Thanks!

Hello DereKoder,

Now that you have to the correct boards installed does it work/upload?

Data cables are pretty standard and will hopefully (as I have found through getting this wrong) have the USB symbol on them whereas ones that are just for power have a lighting bolt on them.

The best way to tell is to plug the board in and see if it is detected by Arduino IDE under Tools → Ports → COM… (Arduino Nano BLE).

Or you can plug in your board and look in device manager under Ports (COM & LPT). You should find something similar to the image I attached to the post.

If you have the boards installed and select and the correct port then it should work.

Thanks,
Matt

Capture.JPG

I used many of the cables I have at home, all of them still have the Nano flash the yellow flashing light on the Nano. The main problem I am having is that it isn't showing up in the ports menu in the IDE or the Device Manager. I will attach a screenshot of what I am seeing in Device Manager.

(mod edit)
nano_ports.PNG

nano_ports.PNG

Hello DereKoder,

When you say the yellow light is flashing, is it flashing with five fast flashes and three slow flashes?

Something that might work is if you quickly press the reset button twice while plugged into the PC. This will cause the light to pulse on and off slowly. This puts the board in "upload mode". If you wait a bit you will hopefully see the board in the IDE. If it does work you should be able to upload a new sketch.

Thanks,
Matt

Hello matt_lee_smith,

No, it does not follow that pattern. I switched it into that mode, and it didn't come up in the IDE. I restarted my computer, the IDE, and switched the modes on the Nano itself too. Nothing works so far. I also switched through all of my other cords. Any other ideas?

I still am having this issue if anyone else has any ideas to fix it after reading through the forum page.

Thanks to anyone who has any ideas!

Your screenshot in post #6 does not look right. Try to uninstall the device, then unplug and plug in again. Wait for a little while for the driver installation to complete.

You have some other COM devices. Please check that the driver for the Ardunio is from Microsoft. Maybe you installed some other serial drivers on your PC. Mine is from 2006 (on Windows 10) directly from Microsoft.

Klaus_K:
Your screenshot in post #6 does not look right. Try to uninstall the device, then unplug and plug in again. Wait for a little while for the driver installation to complete.

You have some other COM devices. Please check that the driver for the Ardunio is from Microsoft. Maybe you installed some other serial drivers on your PC. Mine is from 2006 (on Windows 10) directly from Microsoft.

Check that it is NOT from Microsoft !
The "official" driver is used when the boards are installed via the IDE's board manager.

ballscrewbob:
Check that it is NOT from Microsoft !
The "official" driver is used when the boards are installed via the IDE's board manager.

@ballscrewbob

Mmmm strange. How do I install the official driver? What should I see in the properties dialog for the serial COM?

I just uninstalled the board support and reinstalled it. I also uninstalled the board and driver in the Windows 10 Device Manager. After reinstalling the board support and connecting the board again. I see the same Microsoft driver in the Device Manager, flash downloading and serial works.

I would like to test the official driver so I can give better advice next time.

The official driver should have been installed when you installed the boards in the IDE.

My sense is currently on another project but comes up the same (almost)

2020-05-10 at 00-58-05.jpg

2020-05-10 at 00-58-05.jpg

The same here as Klaus_K. The official package was installed using the board manager but the board connects via the Microsoft driver. It does not show up as Nano 33 BLE under Other devices but as Serial USB-device under Ports (COM and LPT).

When I see the yellow sign in the device manager as shown in post #6, I usually remove that device and let Windows solve it.

Apart from the problem that the board disconnects and not automatically reconnects after upload everything works.

Where would the Nano 33 BLE driver be located? I could do a manual install.

Do you have an option to "roll back driver"

It should be showing in ports com & lpt but as the board that it really is
In this case a nano33 iot

2020-05-10 at 11-01-45.jpg

2020-05-10 at 11-01-45.jpg

OK, I used "Update Driver" and pointed to C:\Users\UserName\AppData\Local\Arduino15 with sub folder option enabled. Windows 10 found a new driver and installed it. I had to do this for two BLE boards separately.
I will give them a try and see if anything is different. Thanks for the help.

Klaus_K:
OK, I used "Update Driver" and pointed to C:\Users\UserName\AppData\Local\Arduino15 with sub folder option enabled. Windows 10 found a new driver and installed it. I had to do this for two BLE boards separately.
I will give them a try and see if anything is different. Thanks for the help.

Does that mean you drivers show the Arduino SA / AG as the vendor ?

OK, I used "Update Driver" and pointed to C:\Users\UserName\AppData\Local\Arduino15 with sub folder option enabled. Windows 10 found a new driver and installed it. I had to do this for two BLE boards separately.
I will give them a try and see if anything is different. Thanks for the help.

It did not work for me. The directory exists but there's no .inf file in it.

Would this solve the changing com port problem?

ballscrewbob:
Does that mean you drivers show the Arduino SA / AG as the vendor ?

Yes, it shows Arduino SA as vendor now. It looks just like your post #13 image.

femmeverbeek:
It did not work for me. The directory exists but there’s no .inf file in it.

Would this solve the changing com port problem?

I suspect Windows took the file from “…\Arduino15\packages\arduino\hardware\mbed\1.1.4\drivers\prewin10”. But I do not know for sure. Windows searched trough the sub folders by itself.

It does not look like it is solving the COM port switching issue. So, far I have not seen any difference.