Arduino Nano v3.0 Not Functioning

Hi,
I recently purchased an Arduino nano (FTDI FT232RL chip), and when I first tried to connect it to my hp laptop it just showed the POWER led(green) and LED4(BLINKING Red).

I was satisfied and decided to try and upload a sketch to see if it was fully functional or not.I opened the device manager and searched for the device but it was not showing up (unlike my Arduino UNO which is working seamlessly ).
Confused ,I did a thorough research on this problem abut could not find a solution.

I learnt that this was not a new problem and many users report that this is a bug in the arduino uno manufacturing and that TEST pin needs to be soldered to the AGND pin of the FT232RL chip .I tried this and this didn't work either.

I've tried downloading every driver that supposedly clears the problem [incl. FTDI VCP driver and CH341 driver (although my chip is original)] ,but how can I do this if the board is not even recognised by the computer (no sound or notification).