arduino uno drivers not installing. help required

ok so I am having all sorts of drama's getting the usb drivers to install.

i have tried going to device manager and pionting it to the drivers file and it still says cannot install drivers,

i have tried on 2 machines one is vista and one is xp and both are doing the same thing, I have tried a different cord also.

any ideas/suggestions?

thanks James

Hi, welcome to the forum. Did you buy an official Arduino Uno, or the cheapest clone on Ebay with a CH340G chip ?

If it has a CH340 chip on it the drivers are here.

The CH340 drivers are certified and built into Windows 8 and Linux.

all sorted, Im using an eleven, I just downloaded the drivers from freetronics site, cheers for the help guys.

I don't mean to high jack your post, but I'm having the exact same issue. I'm unable to figure it out.

I have a clone from eBay with the ATmega328p. It will work with my wife's windows 8 laptop but not with my XP laptop. I've tried updating the drivers numerous times. Any advice is greatly appreciated.

Thanks.