Arduino uno trouble with driver

Hi!

I bought a arduino uno (via ebay) and I tried to install the drivers as described on www.arduino.cc (By the way, I have another arduino mega, which works perfect.) So: 1. I connected the device and windows 7 said that the drivers cannot be found, which is ok 2. I went to the device manager, where I found my under other devices: USB2.0-Serial. 3. If I want to update the drivers, i.e. manually choose the folder with drivers (c:.......\arduino\drivers) the computer says that there are no drivers. 4. If I choose from the list a Port (COM and LPT) and then choose the file from c:....\arduino\drivers\arduino.inf and then click on the arduino uno...it report that the driver was found but that it cannot install it due to error. Code 10. After this in the device manager arduino uno can be seen at ports, but there is reported an error.

So my question is: is something wrong with uno?

Thanks, Jony

It's probably not an UNO with a ATmega16U2 USB-to-serial chip as designed by arduino.cc. Does your "UNO" have a CH340G chip?

It is ATmega328P CH340G UNO R3

Check out this post: http://forum.arduino.cc/index.php?topic=281746.0

My dear friend, problem solved. The link you gave me helped a lot.

So this is the solution: http://www.arduined.eu/ch340g-converter-windows-7-driver-download/