arduino with micro usb type b not recognized

Dear all

I have several arduino boards, some with printer-usb cable and some with micro-usb type b connection.
I also have two arduino wemos D1 boards (with micro usb type b).

The boards with printer cable are recognized, all the boards with micro-usb type b not.

Windows 7 - 64 bits.
CH340b drivers installed.

When I go to device manager, the board is not recognized.

However, when I connected them to a laptop with windows 10, those boards with micro usb type b are connected (but I prefer to program on my other computer).

Anyone a hint ? I don't understand why boards with printer cable-usb work, and with micro-usb type B not ?

Regards
Diederik

Try another cable. Cables with micro USB can often be charge-only cables that miss the data lines.

If you have a phone with micro USB, check if it’s recognised by your PC when connected using the same cable.

Also have you tried a different USB port?

COMMON ISSUES

  • Check you have a COMMON GROUND where required.
  • Where possible use USB 2.0 ports or a USB 2.0 POWERED HUB to rule out USB 3.0 issues.
  • Try other computers where possible.
  • Try other USB leads where possible.
  • You may not have the correct driver installed. CH340/341 or CP2102
  • There may be a problem with the board check your wiring first.
  • Remove any items connected to pins 0 and 1.
  • Boards using a MICRO usb connector need a cable that is both DATA and CHARGE. Many are CHARGE ONLY.

Thanks.
I had tried different cables, but it didn't worked. I checked phones where detected.
I tried again ... and with the 8th cable ... it worked...

Regards
Diederik