Chinese "Nano" not recognized in Windows

Hello, I have been using a morse keyer with the "Chinese Nano" as its core. The nano-compatible board uses USB bridge Holtek HT42B534-1, MCU is LGT8F328P (but this is not important).
After half-a-year of reliable use, this morning suddenly the COM port disappeared from Windows device tree, instead it is reported as "Unknown USB device (device descriptor request failed)".
I tried about 7 different methods to fix it (all found in the internet and youtube howto's) plus tried the Holtek USB bridge setup utility, but nothing helped so far.
Have you had similar problem and were you able to fix it?
Unfortunately the Nano is soldered on a PCB and would be difficult to replace :frowning:

Make sure the USB cable is completely plugged into both the Arduino board and the PC.

You may have a damaged/defective or charge-only USB cable. Try a different cable.

Although those more often will cause the board to not be recognized at all, I have observed it to sometimes cause behavior similar to what you report.

It would be more helpful it you would list those so we can avoid wasting time by recommending them to you.

Hello, these are the 7 methods described in a number of (probably copycatted) howto's in the internet:

  • uninstall device, reboot and reconnect
  • do the same while notebook is not on mains supply (running from battery)
  • in power management setup, disable USB selective suspending
  • ...and everything else...

Unfortunately, when I made the ultimate test, i.e. connecting the device to another notebook, I got exactly same result/error. So it seems the HT42B534-1 chip is gone. Which is unpleasant because the Nano is soldered in a tight PCB (it wasn't possible to use socket).

To look at the complete keyer click the link:
http://www.ok1rr.com/index.php/technical-topics/122-the-tinykeyer

The original employs the original Nano, I took the Chinese clone because it seems to be the only one having Micro USB connector, instead of the outdated Mini USB.

It is sad the USB bridge did not last...

As far as this topic is concerned, I think we should declare it closed.

One more thing, any possibility of shorts or power problems on the Nano?

Hello aarg,
don't think so. Power supply is OK, the keyer works according to program, it only does not communicate as serial port, i.e. it is not possible to use contest software. But as a "plain keyer" it seems to be OK.

What's "funny" - when it happened, I was using a contest program, could see speed indicator changing. One moment I changed the speed from within the program (i.e. the program sent the respective command to the keyer / Arduino over serial port) and I suspect it was then, when the USB bridge "disappeared", whatever it was...

J.

Sorry, today the same device works again. I have no idea what was the reason. If it was Windows problem, I can't explain why the same error happened on two different PCs...

For my latest desktop, I shunned Windows and installed Mint Linux. No regrets.