Com port does not show up when using programming port

Hello everyone!

I have been using the Arduino Due for a project for the past four or five months with no issues. All of a sudden, when I plug in the programming port into a computer there aren't any com ports listed in the IDE or in device manager. When I plug in the native USB port however, the port is listed correctly both in the IDE and in device manager. Normally this would not be a problem, but I need to use the serial monitor for output of data. To date I have been using the same cable, computer, and port on the computer. So far, I have tried the following, with no success:

-Unplugging and replugging the cable
-Trying different ports on the computer
-Trying different computers
-Trying different cables
-I should note that other Arduino boards function normally with all cables, ports, and computers
-Holding reset and erase when plugging into native port
-Uninstalling and reinstalling IDE

For further troubleshooting I have uploaded a simple blink sketch using the native port, and then powering the device through the programming port and the sketch works correctly.

I also tested the two data lines from the USB port to the 16u2 chip, and they hang at ground.

I noticed that the LMV358 OpAmp chip was getting very hot (160F). Performing continuity checks revealed that 5V was shorted to Ground. I removed the chip and confirmed that the short was located on the chip and not on the board with more continuity checks (unpowered board of course :slight_smile: )

I've also looked at the other threads on this and other forums categories, and have tried all of the solutions that I could find, including some that were considered "solved" with no success.

I've also noticed that the digital pins take quite some time to switch between a high voltage and a low voltage. Could there be issues with the crystal?

Does anyone have any other ideas?

Normally this would not be a problem, but I need to use the serial monitor for output of data.

You can use SerialUSB through the native port.

That does allow for printing, but it's not really a solution to the main issue.