[Débutant] Alimentation carte et moteur sur le même adaptateur

Bonjour,

j'essaie de faire un appareil qui doit faire fonctionner deux moteurs, et la carte arduino.
J’ai lus que l’on pouvait utiliser le même adaptateur secteur pour alimenter la carte arduino (uno) et le circuit d’alimentation des moteurs. Mais ça m’effraie un peu et j’aurrais besoin d’éclaircissement/confirmation etc …

Je prévayais ça (sans certitude) :

Je n’ai pas mis les broches, ni les fils des moteurs et j’ai simplifié les entrées-sorties du L293D à une seule broche pour faire plus clair.
A droite ce serait un adaptateur 9V 1A (celui de ma vieille SEGA Master System). Pour le gros condensateur j’ai essayé de faire comme sur un tuto de "zeste de savoir" même si je ne comprends pas bien à quoi il sert.
Ma question : ça serait bon ?
Ca va pas griller ?
Je vais pô faire sauter les plombs ? (ça serait vraiment pô le moment !)

Non, c'est bon. La carte ARDUINO supporte largement les 9V sur VIN.
Par contre il ne faudra pas tirer trop de courant sur les sorties ou la broche 5V.
Le courant maximal sera de ~ 250mA (je ne parle pas de la partie puissance L293D + moteur, seulement de la partie logique).
Avec juste un L293D c'est bon.

Il est bien d'ajouter quelques condensateur sur le moteur :

Pour le gros condensateur j'ai essayé de faire comme sur un tuto de "zeste de savoir" même si je ne comprends pas bien à quoi il sert.

Le condensateur lisse la tension d'alimentation.
La valeur dépendra de la puissance du moteur et de la qualité de l'alimentation.
Il peut s'avérer utile ou inutile. Sans oscilloscope, difficile d'estimer.
Avec un L293D ce sera un petit moteur je suppose.

Vérifier quand même qu'il s'agisse bien de 9V continus.

Avec juste un L293D c'est bon.

Bah en faites il y aurrait aussi un afficheur 7 segments (avec un decodeur bcd), j'avait prévus de ne l'allumer que 3 secondes lorsque j'appuie sur un bouton, deux boutons avec pull_up interne et deux potentiométres.
Ca ferait trop ?
Qu'elle serait le risque ? Pas assez d'ampérage et l'Arduino reset en boucle ou les moteurs n'ont plus assez de jus ?

Je peut peut'être allimenter tout ce petit monde (à part le L293D) par une broche et les éteindre tous lorsque j'utilise les moteurs (ils doivent juste faire une séquence de 20s puis s'arréter) ?

Avec un L293D ce sera un petit moteur je suppose.

Oui ..enfin je crois ..
L’un de mes moteur est un ventilo d’ordi où il est noté : DC 12V 0.15A
L'autre moteur viens d’une imprimante et n’est pas trés gros :

Mais je ne connais pas sa consommation.

Vérifier quand même qu'il s'agisse bien de 9V continus.

Je crois que oui. Mais j'ai peut'être mal lus !?
Je crois que son seul soucis est d'avoir le moins dedans et le plus dehors (pour la prise jack) :

Il va falloir faire un bilan de consommation totale.

Un segment d'afficheur peut consommer 1mA tout comme 20mA, c'est ton choix.
S'il s'agit d'un seul afficheurs, même 7 * 10 mA cela fait 70mA, c'est OK.

Pour les deux potentiomètres, voir la valeur de résistance. Calculer le courant : I = U/R

L'un de mes moteur est un ventilo d'ordi où il est noté : DC 12V 0.15A
L'autre moteur viens d'une imprimante et n'est pas trés gros :

Le moteurs ne posent pas de problème à l'ARDUINO. Ils sont branchés sur le L293D qui est en direct sur l'alim.

Bonsoir,

Si il y a utilisation de la prise jack en bout de transformateur, il faudra vérifier la polarité !
Comme indiqué dessus, le transformateur est un + -
L'aduino a besoin d'un transformateur en - + si on utilise sa prise jack
Les appareils sont souvent protégé d'une inversion de polarité, ce qui est le cas pour l'arduino, mais il vaut mieux être vigilant pour le reste !

Bon déja Merci ! :smiley:

Il va falloir faire un bilan de consommation totale.

En decodeur BCD j'ai un CD4543BE. En cherchant sur son datasheet (je ne sait pas si j'ai regarder au bon endroit) il y a ces deux lignes :

  • DC INPUT CURRENT, ANY ONE INPUT ...........+/- 10mA
  • POWER DISSIPATION PER PACKAGE (pd) :
    For Ta=-55°C to +100°C..............................500mW

500mW (si c'est bien la consommation !?) avec la formule I=Watt/Volt ça ferait I=100mA. Ca serait la consommation "à vide" ? A laquelle il faudrait ajouter celles des segments ?
Les 7 en même temps ça ajouterait 70mA, donc 170mA ?

Pour éteindre l'afficheur quand je ne l'utilise pas j'utilise la broche Blank du CD4543BE, qui éteins tout quand on on lui envoie "1". Du coup j'utilise du courant pour éviter d'en utiliser c'est peut'être stupide ?!
Il serait sans doute plus economique d'utiliser la broche d'alimentation du decodeur BCD, en la mettant à zero quand je ne l'utilise pas !?

Les potentiométres font 10Kohms et 100Kohms, se qui donnerait I=0.5mA et I=0.05mA.
ça ne seraient pas eux les plus gourmants à prioris (!?).

J'ai un interrupteur et deux boutons poussoirs utilisant le pull_up interne placé comme ça :

J'ai lus que la resistance interne est de 20Kohms, ce qui ferait I=0.25mA chacun. Et j'imagine qu'ils ne consommeraient que lorsqu'ils sont fermés (!?).

Sur le datasheet du L293D (je ne suis toujours pas sur de regarder au bonne endroit) il y a :
Iss Total Quiescent Logic Supply
ça donne trois cases variant de 22mA à 60mA. Ca serait juste pour la partie logique du L293D (?!).

Au total la partie logique avec tout les boutons enfonçés et un 8 sur l'afficheur consommerait (peut'être ?!) un peu plus de 231mA (!?).

Ou bien le calcul doit se faire plutôt broche par broche ?

500mW (si c'est bien la consommation !?) avec la formule I=Watt/Volt ça ferait I=100mA. Ca serait la consommation "à vide" ? A laquelle il faudrait ajouter celles des segments ?

Non. C'est la puissance admissible.
La consommation du CD4543BE est négligeable. Voir "quiescent current".

Pour éteindre l'afficheur quand je ne l'utilise pas j'utilise la broche Blank du CD4543BE, qui éteins tout quand on on lui envoie "1". Du coup j'utilise du courant pour éviter d'en utiliser c'est peut'être stupide ?!

Non. Une entrée de CD4543BE ne consomme rien.

J'ai lus que la resistance interne est de 20Kohms, ce qui ferait I=0.25mA chacun. Et j'imagine qu'ils ne consommeraient que lorsqu'ils sont fermés (!?).

Oui.

ça donne trois cases variant de 22mA à 60mA. Ca serait juste pour la partie logique du L293D (?!).

Oui.

Au total la partie logique avec tout les boutons enfonçés et un 8 sur l'afficheur consommerait (peut'être ?!) un peu plus de 231mA (!?).

Il faut retirer les 100mA que tu as compté pour le CD4543BE.