Elegoo Smart Roboter Auto

Hallo,

ich hoffe Ihr könnt mir helfen,

ich habe zu Weihnachten dieses Elegoo Smart Roboter Auto bekommen: ELEGOO Smart Robot Car Kit V4.0 Kompatibel mit Arduino IDE Elektronik Baukasten mit Kamera, UNO R3 , Line Tracking Modul, Ultraschallsensor, Bluetooth-Modul, Auto Roboter Spielzeug für Kinder: Amazon.de: Spielzeug

Ich habe es entsprechend der Anleitung zusammen gebaut und alle Funktionen waren bereits aktiv.
Es ließ sich über die IR-Fernbedienung steuern und über Bluetooth bedienen.
Ich habe mich dann durch die Anleitung gefummelt und versucht dem Arduino One, welcher in dem Auto verbaut ist, die mitgelieferten .ino Dateien zu laden.
Das funktioniert auch alles so weit so gut, nur hätte ich das Auto jetzt gerne wieder so, wie es war als ich es das erste mal in Betrieb genommen habe. Leider bekomme ich es aber nur mit den jeweiligen .ino Dateien zu einzelnen Funktionen und nicht mehr zu allen zusammen zum laufen. Auf Bluetooth reagiert es jetzt leider gar nicht mehr und die IR-Fernbedienung zeigt auch keine Reaktion mehr. Kann mir jemand einen Tipp geben, wie ich es wieder auf Werkseinstellung zurück bekomme ??

Vielen Dank schonmal..

Werkseinstellungen so wie du es verstehst, gibt es nicht.

Du musst den originalen Sketch, so wie er zuvor drauf war wieder drauf laden.
Der ist sicher in deiner Beschreibung irgendwo vorhanden.

Das komplette sketch ist leider nicht dabei, nur die einzelnen Funktionen.
Sobald ich aber einen neuen sketch übertrage ist der vorherige weg.
Gibt es eine Möglichkeit die sketche alle zusammen zu übertragen ?

LG

Saskia

Das Zusammenbringen geht nur "händisch", also wenn du es entsprechend zuvor programmierst.
Und dann komplett aufspielst.

Hast Du schon versucht die ElegooSmartRobotCar_v3_1.ino zu flashen?
Sollte sich auf der beiligenden CD befinden,

Es ist leider gar keine cd dabei. ich sollte mir von der elegoo hp das handbuch und die .ino´s selbst herunterladen... das habe ich auch gemacht, aber da ist leider keine v3_1.ino dabei :confused:

Saskia0501:
Es ist leider gar keine cd dabei. ich sollte mir von der elegoo hp das handbuch und die .ino´s selbst herunterladen... das habe ich auch gemacht, aber da ist leider keine v3_1.ino dabei :confused:

Ich wollte gerade nachsehen, was es dort zum Herunterladen gibt, erhalte aber nur eine Fehlermeldung.

Was für INO-Dateien hast Du denn?

Gruß

Gregor

Wollte auch nochmal nachgucken, aber die seite scheint off zu sein.

Ich habe mal ein paar von den ino´s dabei gepackt die ich so habe.

Ich vermute, daß die SmartCar_core.ino das Objekt meiner Begierde ist, allerdings funktioniert diese nicht.
Siehe hier:

Arduino: 1.8.10 (Windows 7), Board: “Arduino/Genuino Uno”

SmartCar_Core:8:10: error: IRremote.h: No such file or directory

#include <IRremote.h>

^~~~~~~~~~~~

compilation terminated.

exit status 1
IRremote.h: No such file or directory

car_control.ino (2.17 KB)

AUTO_GO.ino (2.21 KB)

car_control.ino (2.17 KB)

Rocker_Control.ino (6.83 KB)

SmartCar_Core.ino (25.8 KB)

Ich hab mir das Komplettpaket nicht runtergeladen (1.5GB, dauert bei mir ca 4 Stunden).
Hier gibts das Komplettpaket: https://www.elegoo.com/tutorial/Elegoo%20Smart%20Robot%20Car%20Kit%20V3.0%20Plus2019.12.23.zip

Das mit der Ino-Datei hatte ich bei den Fragen und Antworten auf Amazon gelesen.

SmartCar_Core:8:10: error: IRremote.h: No such file or directory

Da kann es doch nicht dran scheitern!

Bibliotheksverwalter öffnen und IRremote installieren.

combie:
Da kann es doch nicht dran scheitern!

Bibliotheksverwalter öffnen und IRremote installieren.

Bin völliger Neuling und habe null Ahnung was Du damit meinen könntest... Sorry

Saskia0501:
Bin völliger Neuling und habe null Ahnung was Du damit meinen könntest... Sorry

Wähle Sketch -> Bibliothek einbinden -> Bibliotheken verwalten

Im Feld oben rechts gibst Du „irremote“ ein und wartest einen Augenblick. Dann guckst Du in der Liste nach der richtigen Bibliothek und installierst die.

Gruß

Gregor

Moko:
Ich hab mir das Komplettpaket nicht runtergeladen (1.5GB, dauert bei mir ca 4 Stunden).
Hier gibts das Komplettpaket: https://www.elegoo.com/tutorial/Elegoo%20Smart%20Robot%20Car%20Kit%20V3.0%20Plus2019.12.23.zip

Das mit der Ino-Datei hatte ich bei den Fragen und Antworten auf Amazon gelesen.

Dieses Komplettpaket habe ich ja schon direkt am Anfang heruntergeladen, daher sind ja auch die Dateien, welche ich gerade geschickt habe. Und Obwohl ich da noch gar nichts verändert habe funktioniert die smartcar_core.ino nicht...

gregorss:
Wähle Sketch → Bibliothek einbinden → Bibliotheken verwalten

Im Feld oben rechts gibst Du „irremote“ ein und wartest einen Augenblick. Dann guckst Du in der Liste nach der richtigen Bibliothek und installierst die.

Gruß

Gregor

Und woher weiß ich welche die richtige ist ?

Und woher weiß ich welche die richtige ist ?

Du könntest sie am Namen erkennen.
:o :o :o :o :o Sie heißt "IRremote" :o :o :o :o :o
So wie auch schon die Fehlermeldung sagt.
(den Trick solltest du dir übrigens merken)

Saskia0501:
Und woher weiß ich welche die richtige ist ?

Äh ... naja ... nimm die zweite in der Liste, das scheint die „amtliche“ Bibliothek zu sein.

Gruß

Gregor

combie:
Du könntest sie am Namen erkennen.
:o :o :o :o :o Sie heißt "IRremote" :o :o :o :o :o
So wie auch schon die Fehlermeldung sagt.
(den Trick solltest du dir übrigens merken)

Sorry, wie gesagt, bin absoluter Neuling auf dem Gebiet...
Habe jetzt den zweiten genommen... Und siehe da... es funktioniert.

Vielen vielen Dank für die schnelle Hilfe

Guten Tag und Frohe Weihnachten
Für das ELEGOO Smart Robot Car Kit V3.0
gibt es auch eine github seite

da sind einigs mehr zum Thema und viele Tipps