Fehler beim Sketch Upload

Hallo, habe mir ein Elegoo UNO R3 gekauft und damit ein wenig rumgespielt.
Nachdem ich mit einem Sensor versucht habe die Feutigkeit zu messen, dies aber leider am Sensor scheiterte, habe ich das Problem mit dem Upload.
Ich hatte mit einem Code aus dem Netz versucht über die DHT11.bib den Sensor anzusteueren, ich hab einfach den falschen Sensor, deswegen ging es nicht, nungut, neuen Sensor bestellt kommt Dienstag. Jetzt dachte ich, probiere ich ein paar andere Sachen, nix ist. Ich kann nichts mehr uploaden- der Code von vorher läuft im Serial Monitor ohne Probleme nur eben ohne Werte da kein Sensor angeschlossen. Ich habe folgendes Versucht:

  • die ganze letzte Nacht google benutzt :slight_smile:
  • alles neu installiert
  • Strom ab, Reset drücken- Strom dran, Reset gedrückt gehalten- kompilieren, beim Hochladen den Resetknopf loslassen
  • versucht “leeren” code hochzuladen

Ich bekomme eben nach dem Kompilieren folgenden Fehler
Arduino: 1.6.12 (Windows 10), Board: “Arduino Mega ADK”

Der Sketch verwendet 656 Bytes (0%) des Programmspeicherplatzes. Das Maximum sind 253.952 Bytes.
Globale Variablen verwenden 9 Bytes (0%) des dynamischen Speichers, 8.183 Bytes für lokale Variablen verbleiben. Das Maximum sind 8.192 Bytes.
C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega2560 -cwiring -PCOM3 -b115200 -D -Uflash:w:C:\Users\AppData\Local\Temp\arduino_build_338441/sketch_oct16a.ino.hex:i

avrdude: Version 6.3, compiled on Sep 12 2016 at 17:24:16
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2014 Joerg Wunsch

System wide configuration file is “C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf”

Using Port : COM3
Using Programmer : wiring
Overriding Baud Rate : 115200
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

avrdude done. Thank you.

Beim Hochladen des Sketches ist ein Fehler aufgetreten


wenn ich während des Timeouts quasi den Serial Monitor aufrufe kommt in der Zeit im Log auf “COM3 Port busy” die Kommunikation scheint ja also zu funktionieren oder?

Vielen Dank.

Hast du an Pin D0 und D1 (RX und TX) etwas angeschlossen?
Da sollte beim Upload nix dran sein.

Hey, danke für die schnelle Antwort. Weder an 0 noch an 1 ist bzw. war etwas angeschlossen.

Ach ich sehe gerade, du hast wohl ein falsches Board eingestellt. Muss in der IDE der Uno sein.

Aha, danke irgendwas hat sich jetzt getan. Ich hab das wohl vergessen nach dem neuinstallieren wieder umzustellen oder irgendwas. Danke erstmal, hat mir den heutigen Tag schon versüßt :D

mscherwi: Aha, danke irgendwas hat sich jetzt getan. Ich hab das wohl vergessen nach dem neuinstallieren wieder umzustellen oder irgendwas. Danke erstmal, hat mir den heutigen Tag schon versüßt :D

Ja prima, freut mich, dass es wieder funktioniert.