Filtrage moteur pas à pas

Bonjour,

J’ai un projet dans lequel je pilote 4 moteurs pas à pas via des drivers DM542T. Dans ce projet j’ai également des leds adressables WS 2812B.

Le problème que je rencontre c’est qu’un des trois moteurs renvois énormément de parasites et les leds adressables scintillent. Lorsque je retire l’alimentation du driver de ce moteur je n’ai plus de soucis.

Est-ce que vous me conseillez de mettre un condensateur de filtrage ? Si oui quel valeur de condensateur devrais-je utiliser ? (Alimentation 24V 5A).

Je vous remercie,

Il faut au minimum donner le schéma des alimentations. Je suppose que les leds ne sont pas alimentées en 24V par la même alimentation, ni la carte microcontrôleur. D’où vient alors la tension des autres composants.
J’espère qu’il n’y a pas de confusion entre une alimentation de 24V 5A et les 24A 5V des leds!

C’est curieux que ce phénomène se produise seulement sur l’un des moteurs. Qu’a t’il de particulier par rapport aux autres ?

hello
le cabalge? la proximité (ou parallelisme)du cable moteur et du cable leds?

Les leds sont bien alimentées par une autre alimentation 5V 10A.

J’ai trouvé le problème, c’est un soucis de parasite qui arrive sur la cmd du bandeau leds…
En gros les cables du moteur qui posaient problème se trouve dans le même chemin de câble que la commande des leds. Je pensais pas qu’en basse tension avec des courants peut élevé on pouvait avoir des problèmes de parasites. Je vais donc blinder le cable de la commande des leds.

J’aurais du mieux appliquer mes cours de CEM d’il y a plusieurs années haha

Merci

Un moteur pas à pas c’est souvent 2A avec des commutations dont je ne connais pas la fréquence. De mémoire elle est de 30kHz avec un A4988. Cela fait déjà un bon rayonnement, surtout quand il y a des inversions de courant (+2A suivi de -2A).

J’ai une appli avec trois moteurs. J’ai commandé sur ebay du câble avec deux paires torsadées / blindées par câble. Je n’avais pas envie de polluer la télé de madame, ni celles des voisins.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.