GPS module with arduino uno

Hi Guys,

I have two Neo 6m module from different sellers

  1. Neo-6M-0-001 from AZ-Delivery , it works fine, lights blinks. I am using these module from last year.

  2. Neo-6M-0-000 from Steronics , it does not catch the information from sattelite, no lights blink, even i was outside in open space

first module has 001 at the end and second has 000

I tried a lot but no suceess. Please help me

The 6M-0-000 has firmware version 6.02 whereas the 6M-0-001 has firmware version 7.03
Although you’ll have differences in capabilities, both are supposed to work for the basics.

Depending on the exact model, sometimes you need to get your GPS connected for 20/30 min before you start getting a fix (recharging a battery backed RAM). Did you wait long enough ?

I have given 3.3v to it and i am waiting for the last 12 hours. The module is placed outside. I have 3 modules but no one is catching the information from satellite

do you have a link to your module you can share?

I have bought from berry base. In the picture they are selling Neo-6M-0-001 but actually they sent me Neo-6M-0-000

the module does have an on-board battery

can you check its voltage when not powered?

have you tried powering it with 5V?

(you should complain to them that the picture shows -001 and this is not what they sent you)

This is on serial monitor in open space

can’t do much checking with text on an image… what happened to copying & pasting just the text? :slight_smile:

from the look of it, indeed there is not much fix information coming down

have you tried powering it with 5V?

Most likely cause of that problem is a faulty GPS antenna connection. Or possibly a faulty GPS.

And from the screen shot in #7, you can see the GPS is working OK, but the signals are very weak indeed (hence no fix) which also suggests a very poor antenna, or the GPS is indoors.

I have used the anttena of the first module and its working now. The problem is antenna.

good to know you solved it

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.