how to solve device signature is 0x000000 error.

hello!!
I am trying to upload a blink.hex code to atmega328p using arduino uno (arduino as ISP) and avrdude.
i uses below link for a making the connection and uploading .hex file

first time code is uploaded successfully but atmega328p using a internal RC oscillator, so speed of led blinking is very slow
then i changes the fuse bits setting to 0XFF using below command
avrdude -P com4 -b 19200 -c avrisp -p m328p -v -e -U efuse:w:0×05:m -U hfuse:w:0xD6:m -U lfuse:w:0xFF:m
after this blink code runs as expected.
now the real problem started when i tried to burn another code to same atmega328p using
avrdude -P comport -b 19200 -c avrisp -p m328p -v -e -U flash:w:hexfilename.hex -U lock:w:0x0F:m
this time an error messege appear:
device signature is 0x000000
avrdude: Yikes! Invalid device signature.
Double check connections and try again, or use -F to override
this check.

i googled a lot for solution but till now i not able to fix it. then i bought a new ATMEGA328-PU wire it properly (recheck it) but again after uploading i got the same error message.
is there any problem in arduino uno while working as ISP, if not kindly suggest how can i solve this error. :frowning:

When I had this error I fixed it by pulling everything off the bread board and reassembling.

0x000000 usually means "bad wires"

sorry for late replying.
i solved the problem, and it is because of wiring fault in breadboard.