IOT Device Manager Problem

Hello everyone
I am so slowly despising the "DEVICE" manager in the IOT Cloud. >:(
I have easily added an MKR 1000 through this setup manager and this MKR1000 is also in use.
I wanted to add another MKR1000 and now something strange is happening: :o
I start the manager via "ADD DEVICE", the Arduino is found, I press "CONFIGURE" and enter the name, after that the "SETUP DEVICE" starts step 1, 2 and also 3 only then the program just stops, the "DONE" button just doesn't come and I can't finish the installation.

I have already tried the following:
Disconnect and reconnect Arduino
Restart PC
Swap USB cables
Create a completely new account
All Windows updates running
The plug-in uninstalled and reinstalled
Multiple browsers tries Chrome, Edge, Firefox, Internet Explorer)
The browser history and cache emptied
Nothing helps....
I'm using Windows 10 on a Surface
I hope that someone can help me here, because I find nothing about the problem on the Internet either.
Oh so, the Arduino is therefore not in the transport foam on a non-conductive plate.
Example sketchI can upload, the LED also lights up green....
Have a picture attached as that looks.

Best regards
Nic

There is more information about this issue here:

Thank you,
here is a link to two other people who have problems with it:

pert:
There is more information about this issue here:
MKR 1000 can't be registered through the IoT site because the bin doesn't exist on Arduino's server · Issue #10960 · arduino/Arduino · GitHub

Is there any workaround or resolution to this issue? Or when can we expect a fix?

I don't know of any workarounds for it unfortunately.

Now it works. :slight_smile:

Thanks for the update @nicolasdebusmann. I'm glad to hear it's working for you now!