IRF3205 circuit

Hello, I have a schematic below of an IFR3205, I also have a picture of an empty pencil cap wrapped in magnet wire(5 OHMS).

I am attempting to make a rudimentary coil gun. I have just received my IRF3205 in the mail and I have hooked it up as shown in the schematic and I am powering the whole thing with my DC benchtop power supply and it lets me read the current it is drawing.

Pretty much when I hook up the coil to my power supply through JUST a pushbutton I am able to pull the full 5 AMPS from my power supply. But when I hook it up as shown in the schematic I am only able to pull 1.6 amps. I understand OHMS LAW- My coil is 5 OHMS and my power supply is 12v----- 12/5= 2.4 amps.

Why without the MOSFET circuit am I able to pull 5 AMPS and with the circuit only 1.6 amp?

The IRF3205 isn't switched on at 5V. It takes 10V to be fully on. So for Arduino use its questionable.

The datasheet shows its on-resistance spec'd only for Vgs=10V It would need a specification at Vgs=4.5V or so to be suitable for use direct from 5V logic.

With a pushbutton to 12V it will work, assuming the wiring and supply can handle it. I notice a breadboard just out of shot. Breadboards are not rated for anything like 5A.

Whoever drew that schematic has
questionable electronics experience.
Why do I say that ?
Nowhere in your post are the following :

  1. Wire Guage
  2. Wire length
  3. Coil Inductance

Coils are inductors.
Inductors are rated in Henries (H), not ohms,
so a coil shown on a schematic as:
“5 ohm coil”
is basically meaningless.

Whoever created that schematic has no
electronics training because the American
Wire Guage lists the resistance in ohms
per thousand feet.
Since you have posted no wire guage let’s
use 30 guage (30 AWG) as an example.
At 103 ohms per thousand feet , you
don’t need a calculator to realize it is 103.2
mOhms PER FOOT. If your “target” is 5 ohms
(as inapprpriate as that is for a “coil”)
then 5 ohms divided by 103.2mOhms (0.103 Ohms) = 48.5 feet.
Wouldn’t it make more sense to simply instruct
someone to construct the coil with 50 feet of
30 guage wire ? (Actually , based on the photo,
that wire looks to between 40 and 30 guage (smallest to largest guage) but you can look up
the Rho (resistance constant, which is always
given for copper oneire guages ( Rho differs
for every material)
Did you measure the coil resistance ?
Did you read the mosfet datasheet for Vgs ?
Maybe 5V<Vgs in which case it won’t turn on.
You could you a gate driver like the TC4427.
It runs on 12V but takes a 5V gate drive signal.

I am the one who drew the schematic, I am still a beginner level. When I put 5 OHMS I should have clarified that is the coil's resistance.

The wire gage is 30AWG and I didn't measure the length but I would say 40 feet or so seems about right.

I don't know what the inductance is.

The VGS is 20v ( which was my problem because I was powering the circuit and the gate with only 12v, so I wasn't able to get the full amperage.

1)So the VGS is what it takes to fully saturate the transistor?

Mosfet

Read Marks post.

raschemmel: Mosfet

Read Marks post.

I am a little confused, the datasheat said that the Vgs is 20v, not 10v.

Read the title at the top of the column, where it says"Max". 20V the max Vgs ,not the normal operating Vgs The max continuous drain current is given for a Vgs=10V. If it works to obtain the max current, it must therefore work for anything less than that.

raschemmel:
Read the title at the top of the column, where it
says"Max".
20V the max Vgs ,not the normal operating Vgs
The max continuous drain current is given for a Vgs=10V.
If it works to obtain the max current, it must
therefore work for anything less than that.

I have tried powering the gate with 12v and 10v but i am not able to draw the max current. Only when i used 20v on the Gate was i able to draw around 5 amps.

Post a drawing with the MOSFET leads (S, D, G) identified. (With darker lines, please).
Nmosfet1.pngmosfet220_1.png

Nmosfet1.png

mosfet220_1.png

JCA34F:
Post a drawing with the MOSFET leads (S, D, G) identified. (With darker lines, please).
Nmosfet1.pngmosfet220_1.png

My Mosfet is the same as your first picture. But i already know why i wasn't drawing the full current is because i was powering the gate with 12v and not 20v.

What i don't get is what raschemmel was trying to says. When i used 12v on the gate, i was only able to draw 1.8amps, but when i powered the gate with 20v, i was able to draw the full amount of current from my power supply.

Is that how it should be? Or should it be able to fully saturate at 12v?

Can someone explain in easy to understand way?

That MOSFET (if not damaged) should be fully saturated with 10V Vgs, make sure you have: Top of coil to 12V+, bottom of coil to Drain (look at 2nd picture), Source to 12V-, button from 12V+ to 220Ω resistor to Gate, don't forget Diode in parallel with coil with cathode to 12V+.

JCA34F:
That MOSFET (if not damaged) should be fully saturated with 10V Vgs, make sure you have: Top of coil to 12V+, bottom of coil to Drain (look at 2nd picture), Source to 12V-, button from 12V+ to 220Ω resistor to Gate, don’t forget Diode in parallel with coil with cathode to 12V+.

I do have it connected like that,but here http://www.irf.com/product-info/datasheets/data/irf3205.pdf , it says VGS is 20v and in my circuit it only draws full current with 20v on gate.
I will try and take a picure.

I do realize that im using a breadboard to draw 5 amps and i probally shouldnt but i know it works. because when i do the same setup with just a pushbutton it draws 5 amps or it also draws 5 amps when i put 20v on the gate.

20V Vgs is in the ABSOLUTE MAXIMUM table, if you put more than that voltage on the gate the transistor may already be damaged. Do this: Put your black voltmeter probe on 12V-, red probe on top of coil. What voltage with button pressed and not pressed? Put red probe on bottom of coil. What voltage with button pressed and not pressed?

Fig. 3 on page 5 shows maximum drain-source voltage when gate-source voltage is 10V (@25 deg C) or 12V (@175 deg C), so I have to agree with everyone else that based on the datasheet, you should get maximum drain-source current when Vgs = 10V. The datasheet says that 20 is the maximum you can apply but it does not say you need to apply that much. On the contrary, it says the continuous maximum drain current of 110A (@25 deg C) is given for a Vgs of 10V (not 20V). It is a mystery why it is necessary for you to apply a Vgs of 20V.

I am also using a uf4007 diode

Did you do those voltage checks? Earlier you said your coil resistance was 5Ω and you had 5A through it. That would take 25V. Did you put 25V on the MOSFET's Gate?

JCA34F:
20V Vgs is in the ABSOLUTE MAXIMUM table, if you put more than that voltage on the gate the transistor may already be damaged.
Do this: Put your black voltmeter probe on 12V-, red probe on top of coil. What voltage with button pressed and not pressed?
Put red probe on bottom of coil. What voltage with button pressed and not pressed?

Ok, i just set my benchtop power supply to 10v. I am using the same 10v line through the push button to gate

Top coil (side closer to 12v+)
button pressed - 10.2v
not pressed- 9v

bottom coil ( side attached to drain)
button pressed- 10.2v
not pressed- 0.8v

JCA34F: Did you do those voltage checks? Earlier you said your coil resistance was 5Ω and you had 5A through it. That would take 25V. Did you put 25V on the MOSFET's Gate?

no the max I put was 20v, that is basic OHMS law right 25/5 = 5 amps

So that is my problem I believe, I am sharing my gate voltage with my power supply, but since it took a higher voltage going across the Mosfet to achieve 5 amps, i should probably power my gate with a separate 10v supply with a common ground, so i can not damage my MOSFET and still be able to use a higher voltage to achieve my acquired 5amp draw.

I believe that was my problem, i am right?

You either have a normally closed button or the MOSFET’s damaged or connected wrong. Do you have another MOSFET?

button pressed - 10.2v

Does that mean MINUS 10.2V?
With the right components the values should have been closer to:

Top coil (side closer to 12v+)
button pressed , > 9V
not pressed, 10.2

bottom coil ( side attached to drain)
button pressed, < 1V
not pressed, 10.2v

JCA34F:
You either have a normally closed button or the MOSFET’s damaged or connected wrong. Do you have another MOSFET?Does that mean MINUS 10.2V?
With the right components the values should have been closer to:

Top coil (side closer to 12v+)
button pressed , > 9V
not pressed, 10.2

bottom coil ( side attached to drain)
button pressed, < 1V
not pressed, 10.2v

I will double-check my voltages
nut am i correct in what i said in comment #17?
thanks