Issue uploading with nano

just bought an arduino nano to work on a model rocket TVC project, plugged in a servo for initial tinkering, and every time I hit upload on the sweep test I got:

avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00

Looked around, saw some suggest changing the bootloader to old, tried that, and nothing. Any suggestions? (the board itself is alive FYI)

Did you install the CH340 drivers for it?

no I do not think I did, how would I go about doing that?

ok it is installed in advance, Im using COM1, that is the only 1 available for me to use

COM1 is usually not the Arduino; if it's the Arduino, it will disappear from Windows device manager when you disconnect the Arduino.

If your Arduino has the CH340 chip (check the writing on the chip on the bottom of the board), you need to download the driver from CH341SER.ZIP - Nanjing Qinheng Microelectronics Co., Ltd. and install it.

Lastly, your 328P micro my have the old boot loader; you can play with the settings under tools -> processor to get a succesful upload.

What do you mean?
You can download the drivers by searching “CH340 drivers Sparkfun” and just follow the instructions. Once those are complete, you can connect you board to you device and go to Device Manager (if you are on Windows) and under the COMS and Ports tab, you should see CH340 written with the port number. Upload a simple sketch with that port, and if it doesn’t work the first time, switch the bootloader to the old one. A lot of clones use a CH340 with an old bootloader.

Tried installing that driver you linked, but windows gave me a message saying it was already installed. Checked IDE, and still only COM1 showed. Might try a different device.

What does Windows device manager say about the device when you plug it in? Any yellow exclamation marks?

What are the VID and the PID; in case you don't know how to find them, see Cannot upload to my brand-new Arduino Nano - #12 by sterretje to find them.

If Windows device manager does not see the board at all, you might have a bad cable or it might not have been inserted properly at one or both sides.

The only thing I see under the COM list is COM1 in device manager, nothing mentioning the chip.

For reference,I am using a splitter where it has all sorts of cable types coming out of a little box, I plug the usb into my computer, and the end for the nano into the nano, and it powers on fine. if I need a pure cable and not one of these splitters, I’ll buy one.

It does not have to be under the COM list.

  1. There might be an entry somewhere under something referring to USB in which case it's a driver problem; does device manager refresh when you connect/disconnect the board? If so, find the differences.
  2. As long as it does not show under the COM list, there is no hope that you can do an upload.

Maybe that splitter is for charging only and is missing the data wires. If you connect your phone to it (assuming you have a mobile phone), does Windows recognise it and can you download e.g. images from your phone to your PC?

A dedicated data cable is never a waste.

Your cable/splitter might be the problem, though I doubt it would be.

Is the wire thin and very flexible compared to some other cables you have?

If yes, then it is a charge cable with only a plus and minus wire. Try using a thick wire connected directly to the computer. Pictures of the board (underside) and setup would be great

This is what I am using to hook up to my computer

Board is an authentic, brand new arduino
Nano.

Board isn’t recognized when using the splitter. I’m highly convinced the splitter is the issue. Ordering an actual cable tomorrow, hopefully will be uploading successfully by the weekend.