MKR1000 WiFi101 shield: NOT PRESENT

Hello.
I have 3 MKR1000.
I’m testing it with CheckWifi101FirmwareVersion example… but i can do it work.
serial console show this message.
WiFi 101 shield: NOT PRESENT.
image attached for more info.

I use only usb cable… never connect any devices mkr1000.

3 devices, all new , but all show same message. :frowning:
thanks.

you need to upgrade your Wifi101 Library !

Had the same issue, just get it from GitHub - arduino-libraries/WiFi101: Wifi library for the Arduino WiFi 101 Shield

Thanks

Dear all,

I have the same issue with my MKR 1000: "WiFi101 shield: NOT PRESENT".

I've thus checked the WiFi101 library as stated above but, according to Arduino IDE 1.8.5, I have already the last version: 0.15.2.

Then I tried to ignore this and followed the procedure in order to properly update the firmware.
The Test connection is successful. I have a MKR 1000 with the "MR510PB" written on the chip so I selected the model B 19.5.2. Clicking on "Update firmware" yields: "Error while erasing flash memory".

I googled this but found so far articles concerning only the Shield and/or Adafruit products. Besides this I can upload sketches such as Blink without issue. Today the board appears on COM18 and clicking "Get board info" gives "Native serial port, can't obtain info" whereas Windows' Device Manager shows "Arduino MKR1000 (COM18)"...

My MKR 1000 was bought on the Arduino online store, properly selected in the board menu and I installed the latest SAMD board driver when I set it up: 1.6.18

Thank you in advance for your support!

The "WiFi shield not present" error can happen if you are not using the proper WiFi examples from another WiFi library.

Make sure you have installed the correct ones as some are MKR specific and some are the old wifi shields (non MKR)

It can be a little confusing at times but make sure they are the SAMD specific ones.
It is less of an issue when using the CREATE editor I find.

Use the examples from the "WiFi101" NOT the "WiFi" lib.

Thank you ballscrewbob for your quick answer.

Unfortunately I was already using the WiFi101 examples (Files > Examples > WiFi101).

Good news: I've tried with another MKR 1000 and it worked well. So my problem is board specific. Any other hint? I was especially using a USB2.0 port in both cases. I've noticed the second board got COM6 whereas the "defective" one got COM18. Could it come from the 2-digit COM port?

Second topic related to this second MKR 1000: I noticed while testing it that the CheckWifi101FirmwareVersion told me this board had 19.5.2 but that 19.5.4 was available. However it is not available in the drop down list of the FirmwareUpdater. After looking on the Arduino forum the recommendation is to update the WiFi101 library - but again I already have 0.15.2 installed and no earlier version is available in the Library manager... - or to update the IDE - here also I have the latest version 1.8.5. Any hint is welcome as well :slight_smile:

Regards

Windows COM port issues only start to appear from around COM 30 so probably not that.

Have you tried the "quickly double tap the reset button" to put it into BOOTLOADER mode ? (will appear on a new COM port)

If you can get it into boot loader then simply push the blink or bare minimum example up to it.
One you have done that and if that works you can start to try to update the firmware again by sending the UPDATE FIRMWARE sketch at it again and then follow this tutorial