NANO RP2040 odd connection issues

I m facing very similar problems from day one I purchased an nano RP2040.
Tried different (original arduino) RP2040 boards, computers (including Mac), USB cables. Tried different arduino IDEs, mbed OS with no result. No problems with Mega2560 board though. Tried all the described routines, including flashing with blink.ino.elf.uf2 which works in principal, but almost every time I load a new sketch, either the programm cannot be loaded or the USB port connection is corrupted.
I m using Win10, so CH340 should not be the problem, but the PC does not recognize the board whenever I replug ("unknown usb device (device descriptor request failed)").

For linux users, running this post_install.sh file seemed to help in some cases, but I have no idea if and how something simlar could be done on Windows.

Some of the behaviour appears rather unsystemically, so not sure where the problem really is.

This is really annoying, so any help is greatly appreciated.

Thank you!

Please start here:

thanks for the quick reply, but as mentioned, I m using Win 10 which has CH340 preinstalled & reinstalling with the mentioned .exe does not help. The link at electropeak is not working by the way, a better source is:

https://cdn.sparkfun.com/assets/learn_tutorials/8/4/4/CH341SER.EXE

That's a big nope
Also this is a necro post. I'd expect the mods to break it off into its own post.

well I read that in a forum but did not counter check, my bad. In any case, I had the drivers already installed. Installed them over the "old" install though with no change.

  • in the meantime, tried disabling driver signature enforcement before installing as described here:

Did not work either.

That's because the RP2040 does not requires CH340 drivers.

Did you read the sticky about installing the board cores in the other newer NANO sections ?

ermh, if you mean like trying different versions of the mbed OS (2.3.1-2.5.1)? .. yes, tried that.

@pert You have an RP2040.
Anything you can add ?

Did you try post_install.bat and core v2.5.2 ?

PS: As I don't use Windows, I don't know if this will help you or not. Possibly not as it was written for Portenta_H7, sorry

well it s an original arduino one, meaning (as far as I get it), no ch340 chipset.

The most obvious thing to me is that Win10 reacts somewhat ambiguous towards the rp2040 whenever the serial port is concerned, both recognizing the USB port (under COM & LPT) and signing it as unknown device ( device descriptor...) at the same time (under USB controller) in the device manager. Not a very precise description, but all the above described workaround attempts have failed so far...

actually I have no idea how & where I would run a .bat file correctly. Tried mbed OS 2.5.2 though, if thats what you mean...

Yes, try v2.5.2, also check and disable antivirus software, which can interfere with the port operation in Windows and see if better.

yes, thanks, but that does not make a difference..

I think you have to wait for @pert or @in0

They are both the same user.

1 Like

Ok, so here is a small update on the matter:

Maybe a short description of how to reproduce the error somehow helps in solving this issue.

After a full reset of the RP2040 with installing the blink.ino.elf.uf2 file, the boards works ok (including uploading of different example sketches like "blink" and so on) UNTIL I upload a sketch that among other things calls the serial port (serial.begin, serial.print and the like), leading to the following message:

at processing.app.Serial.touchForCDCReset(Serial.java:101)
	... 6 more 


the sketch itself is yet uploaded correctly, but AFTER THAT, upload of any sketch simply is not possible anymore . Not specific, just "..error in uploading sketch appeared.."

I tried running the post_install.bat in the respective mbed_nano folder with admin rights, but that did not change a thing.

From what I write you see that I am not too much into the details of the arduino world, but my impression is that the Win10 port management somehow is in conflict with the RP2040 board and I am now pretty much out of ideas how to solve this.

Any suggestions though?

Thank you!

Well probably nobody´s listening right now, but I can produce EXACTLY the same behaviour on an iMac, suggesting that it is not some weird Win10 USB port management issue, but an RP2040 specific problem. Given that I used 3 original arduino boards and not some strange clones, this is somewhat frustrating.

Should probably contact arduino tech support directly.

Cheers Moerten

What sketch? Please post the code.

Please explain the steps you took to use mbed os.

Sorry this took so long.

In the meantime I have tried to sytematically boil the problem down to the piece of code that causes the trouble, which is something of a step forward I guess. Due to the setup, I wanted to use a DHT22 temperature/ humidity sensor. With the mega2560 no problem so far, but the RP2040 somehow chokes on that bit of code.

With this:

#include "DHT.h"

#define DHTTYPE DHT22
#define DHT22_Pin 16

DHT dht(DHT22_Pin, DHTTYPE);
float temperature;

void setup() {
  Serial.begin(9600);
  dht.begin();
}

void loop() {
 temperature = dht.readTemperature();
}

I can somehow reliably block the access to COM such that I have to reset the board in order to make it work again. It might be something trivial, but given that I am not really into programming arduinos yet, I cant find the mistake. Should maybe chose a different DHT library?

Kind regards

Moerten