No com port for second arduino

So I have two Uno's and both are running sketches. Both sketches run fine but only one of the Uno's is now showing up in my com ports. They are both powered over the usb cable. I have tried to uninstall and reinstall the drivers but it is always the same, one Uno shows up as com9 and the other does nothing.

I am running version 1.0.3 of the Arduino IDE and used the FTDI and Uno drivers from there.

Any help would be appreciated.

Brian

Hi

I don't know if you're also using Win7 64 bit but I've seen reports of this with that OS and USB generally, not just an Arduino issue.

As I have multiple Uno and two FTDI adapters I also sometimes find Windows 7 does strange things when enumerating the USB ports so I've gone into control panel and renamed the ports used by them to get them out of each others way. For example my Uno's I've now numbered from 20 down. Sometimes also (and only on my Windows 7 machine) plugging a Uno in which works well most other times it will be recognised and almost immediately disconnected - plugging it into a different USB port will normally fix this (so I end up swapping the USB ports for both Unos since I only have 2 on the front panel of that PC...and oddly that usually fixed it first time)

Hope this helps you find your issue, Geoff

Hi,

I have tried three different machines now. Unfortunately they are all Win 7 64bit. But in all three cases Windows failed to even recognize that something had been plugged into the USB port. I read this blog which describes the same problem and how it was fixed by re-flashing the ATmega8U2. Here is a link to the blog:

http://blog.ethanfrei.com/2011/10/arduino-uno-revived.html

I am not sure if I my Uno has the 8U2.

Brian

Does one always work and the other never? Or does this happen if both are plugged in?

I am not sure if I my Uno has the 8U2.

You can tell which chip is on it if you have good eyesight.

It's the chip to the left of the Tx/Rx LEDs.

If one is a earlier Uno and one is a R3 Uno you may have to install different drivers.

One always works and the other is never detected. I have tried them together and one at a time. They same one always fails, that is it is never detected by any of my machines.

Thanks for showing me where to look. Looks like mine is the ATMega16U2. I guess I will try to reflash the 16U2. Do you know if this can be done using my other Uno or do I need to get a USBTinyISP?

Brian

So 1 is not working at all?
When you plug it into the PC(no other arduino is connected) does the PC recognize that something is plugged into the USB port?
If not it may be something wrong with the connections or the USB interface.

Correct, one never works at all. I have tried three different PC's and none of them recognize it at all. I can use the same USB cable and my other Uno IS recognized on all three.

Just thought I would report my findings in case it will help some one else. The Uno that wasn't connecting was mounted to an aluminum plate. The plate is grounded and the sketch runs fine but it will not connect via USB to any computer. I removed the arduino from the plate and now it connects just fine.

Now to figure out why the mount is causing this failure.

Brian