OSX 10.8 - Arduino Due - Serial ports not showing

Hello,

I recently purchased an Arduino Due.
It is connected to an usb port at the programming port.
In the Arduino IDE under Tools → Serial Port no usb ports show up (only bluetooth ports).

I installed the latest version of FTDI VCP drivers following advice found on the internet but that didn’t help.

What could the problem be? Anything except maybe a malfunctioning micro b usb cable?

(This is on a Mac running Mountain Lion and I do get a green on-led and an orange blinking l-led)

FTDI VCP drivers

Well, Due doesn't use an FTDI chip, so that won't help any. The driver for the 16u2 chip used instead SHOULD be built into the Mac. (it would show as /dev/usbmodem* instead of /dev/usbserial*, but that shouldn't fool the Arduino menu.) When you say "programming port", you mean the one closest to the power jack, right?

While the Due is connected, run "System Information" (type into spotlight), select USB. Do you see anything Arduino related listed there?

Hi, thanks for your replies!

@westfw Okay thanks for clearing that up about the FTDI drivers. I was looking for /dev/usbmodem but unfortunately I couldn't find anything. And I think I have the right port (It says programming underneath it?). I thought the one next to the reset button was native USB.

@James C4S While I'm not 100% sure what I'm looking for, I don't find anything that resembles Arduino and no additional entries show up after plugging in the Arduino.

The fact that 'nothing happens' on the computer side when i plug in the Arduino led me to believe the issue might be the cable, as I got this cable separately from the Arduino. But how likely could the cable 'not work' but still provide electricity to the Arduino? If it's not the cable however I really don't know what the issue could be.

webmaki: I don't find anything that resembles Arduino and no additional entries show up after plugging in the Arduino.

Did you hit CMD-R to refresh the entries?

webmaki: But how likely could the cable 'not work' but still provide electricity to the Arduino?

It is extremely likely that the cable is only designed to provide power and no data signals.

@James C4S I did hit cmd-r. And interesting! I always thought those cables were uniformly designed - but if micro b usb cable ? micro b usb cable that is probably the issue. Thanks for your reply and I will try to obtain a new cable before trying anything else.

Were you able to resolve this?

I received my Due today and it too isn't showing up in the serial port menu. Whether it is plugged in to the native usb port or the programming usb port, it doesn't appear. I checked System Information and it doesn't get listed in the device tree. Running ioreg in terminal didn't show the device either.

I thought it might have been not enough power over the usb cable so I plugged in 5v in the DC jack and still no luck.

Is there a way to reset the Due?

Any help is greatly appreciated.

EDIT: I should add that the L led is solid along with the On led, if that means anything.

EDIT 2: I downloaded the IOUSBFamily Log Release from developer.apple.com to see if the OS X usb subsystem could shed any light on the situation. The only console message that might be related is this.

1/26/13 7:04:58.758 PM MDCrashReportd[326]: 326:2042986880|MDCrashReportd.m:deviceAttached| ERROR: Could not get a USBMux endpoint for the device with uid b7010c79b5bb8aa7f15161ad8d5af162f5ac38af. Ignoring.

It is had to ascertain whether this message is related to the Arduino Due at all as it does show any usb id's in the message.

It looks like the Due is bricked. Can anyone tell me if there is a way to unbrick it?

Thanks again, Greg

Anyone able to help?

Have you tried a different cable?

I tried the cable on another device and it worked fine. I bought another cable and the Due still refuses to show itself.

I guess it's time I bought the black magic probe and see if I can recover it that way. Does anyone have a link to the steps needed to reburn the boot loader?

Thanks, Greg

If neither port is showing up, I'm not sure that indicates a bootloader issue since the ports are connected to different chips.

Neither the programming or native port is showing up. What does it indicate? DOA?

I just checked the console logs while plugging the device in

When it is plugged into the programming port, nothing is displayed. When I plug it into the native port it displays this

http://pastebin.com/EeguJzJ7

You might get a multimeter and check to see your rails are correct. You can probably use the ICSP header near the ATmega16u2 to check its voltages.

I suppose its possible that if one chip didn't get programmed at the factory, the other didn't. It just seems strange that neither enumerates.

I see 4.91V on the ICSP and also on the 5v pin. I also see 3.27v on the 3v pin.

I plugged it into the windows box i have and when connected to the programming port it doesn't do anything and when I plug in the native one, windows complains about the USB device having an issue.

I've just ordered the black magic probe to see if i can recover the device, if not I will send it back for replacement.

I'll keep this thread updated for the resolution.

Thanks, Greg

Greg: I'll keep this thread updated for the resolution.

Or you might consider starting a new thread with the resolution since it really has nothing to do with the original poster's topic.

True. Will do.

g

Hello, i have the same Problems: ATmega 168 with a MacOX 10.6.8 PWR light is green 13 red is blinking...tried 4 different USB Cables , on Systemprofiler no Arduino device shows up .

please help ;)

Truegrip: i have the same Problems: ATmega 168 with a MacOX 10.6.8

No, you don't have the same problem. The due doesn't haven't an atmega168.

You likely have a board at uses a FTDI chip and so you need to install FTDI drivers.

Truegrip: PWR light is green 13 red is blinking...

Red... So it isn't an Arduino.