RP2040 Nano Connect on Windows 7

Anyone have any luck getting the RP2040 Nano Connect running on windows 7? I tried installing it from the Board Manager but it wont accept the driver. In Device Manager it shows up as RP2040 Nano Connect but has a red X. I browsed to the prewin10/arduino_mbed.inf file in the user AppData directory, but it wouldn't recognize that as a driver. I right clicked on that file and chose install, but the error message was 'The INF file you selected does not support this method of installation'.

Any help would be great.

Is this an official board or a clone? The clones can have a different USB chips.

It’s an official board, I ordered it from arduino.cc store.

Ok, good info. I think @pert has a lot of info on this as do many others. I'm sure someone will help soon enough.
Also, what version of the Arduino IDE please?

My ide version is 1.8.12.

@studiogamma Could you please post a screenshot of the error you got here for us to take a look at?
Try doing the steps below:

  1. Install IDE version 1.8.15
  2. Open it and go to "File - Preferences - Additional Boards Manager URLs", add
    http://downloads.arduino.cc/packages/package_staging_index.json, click ok.
  3. Now go to the IDE's board manager and search for "RP2040 Connect" and install the latest version of the core.

I followed these steps, but the driver still wouldn’t load. When I browsed and selected arduino_mbed.inf from the app data pre-win10 driver directory it only showed Nano iot 33 BLE.

@studiogamma Have you tried the steps in another computer? Are you using official Arduino Nano iot 33 BLE? If you use a bad USB cable, it will never connect (Use a data USB cable capable of 480Mbps and do not use a USB hub or USB 3.0 port.)

Did you screenshot your device manager?
Sound like the device is installed but disabled by Windows.

A few things:

  1. I'm using the RP2040 Connect, trying to install it on Windows 7.

  2. I know its official I bought it on arduino.cc.

  3. Also I did get it working perfectly on a Linux Mint desktop. I had to run the post_install to get it working. ( I also tried that with the Win7 with no luck).

I attached my screenshot of the device manager.

Can you show us a couple more things please:

  1. Your system manager so we can see the version and build of Windows
  2. What does it say when you click on the Driver not installed successfully

Please screenshot both of those.

It's apparent that your Nano is ok because the same Nano worked on another machine. Please be sure to use the same USB cable that worked with it on the other machine.

Try 1.8.15

I'm now using IDE 1.8.15.
Here's the windows version
Version 6.1.7601 Service Pack 1 Build 7601

The screenshot is when I clock on 'driver not installed correctly'.
rp2040ss2

Try this fix:
Nano RP2040 Driver not able to load - Using Arduino / Installation & Troubleshooting - Arduino Forum

The driver in the prewin10 directory’s for that GitHub site shows the arduino_mbed.inf file as 2 years old. The rp2040 isn’t that old.

In device manager I tried update driver and browsed to that file. It said Nano 33 iot BLE. Nothing about the rp2040.