Schmitt Trigger Oscillators?!

Schmitt Trigger Oscillators

i'm using a 50k resistor and a 33uf Cap, am i missing something obvious here? other than GND and 5v and pins 1/2, exactly as in
this schematic, the LED lights up nothing else..

Don't tell me I need to tie every none used output to gnd? or seems something's missing and i can't for the life of me get it to work?

Anyone have a tried and tested Schmitt Oscillator Circuit I can pinch from you? :slight_smile:

I'd be happy with any kind of oscillation between 1 - 50hz, something visible to the naked eye

Thanks :slight_smile:

Go find a copy of Donald Lancasters book Cmos Cookbook.. The information is there. There is a whole chapter devoted to this most handy little circuit and it's many variations.
Your likely issue is not enough gain in the gate package. The 'HC14 takes 3 sections,, It doesn't work well with one.
What IC are you using for the gate? a 74CH14? try a CD4069UB or a CD40106 (CD4584?) I've used both..
An interesting circuit the gates need an inversion to work so it is necessary to use 1, 3, 5... always an odd number. This circuit is most often used as an oscillator for an led used a blinking annunciator.. as it can be gated with a diode, cathode to the gate (for a dual package use the C. When the input is low the oscillator will run when high it will stop. Very handy sort of electronic glue for the designer. These are typically implemented... when the designer has run out of other options to blink a light or beep a sounder. The circuit also makes a good oscillator for resonators and 'some' crystals too, With a 4069UB the device has been successfully used ad a linear amplifier for small microphones... Too.

Bob

I'm using an sn74hc14n

pin 1 being the input attached to the Cap and Resistor, and pin 2, the other end of the Resistor as in the circuit (identical) the only difference is i connected the output (pin2) to
2222a transistor via a 1k resistor, and a 240ohm to limit the current to the "blinking" LED.

really, i've just built a 4060b oscillator circuit with a precise 2hz pulse going into a D-flip flop, to reduce it down to 1hz, no problem.

why can't this seemingly simple enough circuit behave, I'll swap it for a NAND gate and tie the inputs, but i don't see it making a difference, what i need is a working
circuit.

Do you need some kind of magic dust to get the thing working?

I have it blinking with a 88k ohm resistor and 10 uF cap.

And i have a lot of dust here, but I don't think it is magic

No just the right chip, your choice of the HC14 was the error, easily fixed, either use 3 gates of a 74HC14 or 1 gate from a CD40106 or a CD4584. You can also use a CD4093 if you tie the inputs together or use one input to gate the oscillator, which is a better option than my suggestion above because there is no startup delay as there is with the diode gate, I've used both many times on many different configurations. Once I set one up driving the gate of a BIG mosfet which switched 12 v to an ignitiion coil and a spark gap that was coupled to a 75 cm ring of 10 Ga copper wire and a 100 PF cap @ 10 KV... Made a great noise source to do a rough noise immunity test. When I initially tested it... It destroyed 3 calculators I had on my bench... About 100 watts of power @ ~ 50 MHz... in 2 hours... From scratch.. @50 MHz. Note: The device was an AM transmitter making power @ 50 MHz modulated by the 2KHz signal from the Cmos gates...

Bob

An interesting circuit the gates need an inversion to work so it is necessary to use 1, 3, 5… always an odd number.

I just tried with in/out 2a/2y, and it worked the same way ?
I am using SN 74HC14N

Erni:
I have it blinking with a 88k ohm resistor and 10 uF cap.

And i have a lot of dust here, but I don't think it is magic

I'll pay you for your dust :stuck_out_tongue: - just scoop it up, put it into a bag a ship it lol

88k and a 10uf cap, huh 3am now i'll give it a go in the morning, thanks for trying it :slight_smile:

Docedison:
No just the right chip, your choice of the HC14 was the error, easily fixed, either use 3 gates of a 74HC14 or 1 gate from a CD40106 or a CD4584. You can also use a CD4093 if you tie the inputs together or use one input to gate the oscillator, which is a better option than my suggestion above because there is no startup delay as there is with the diode gate, I've used both many times on many different configurations. Once I set one up driving the gate of a BIG mosfet which switched 12 v to an ignitiion coil and a spark gap that was coupled to a 75 cm ring of 10 Ga copper wire and a 100 PF cap @ 10 KV... Made a great noise source to do a rough noise immunity test. When I initially tested it... It destroyed 3 calculators I had on my bench... About 100 watts of power @ ~ 50 MHz... in 2 hours... From scratch.. @50 MHz. Note: The device was an AM transmitter making power @ 50 MHz modulated by the 2KHz signal from the Cmos gates...

Bob

cool, glad you cleared that up for me, cheers :slight_smile:

again, i'll swap to another logic IC and try again ..

Muchos Gracias.

That circuit is so very handy.. so many uses for it and when you disconnect the feedback makes a great input conditioner for any type of mechanical switch... Add a couple more gates and make a mic preamp for an electret microphone... Makes a great noise sensor with a pot for threshold setting. With 40 DB of linear gain. (CD4069UB only).

Bob

You have to be aware of the difference between buffered and unbuffered CMOS gates (at least in the CD4000 series),
as the buffered versions have extra inverters on inputs and on the outputs - for many of the cunning CMOS analog
circuits you need the UBE versions (unbuffered) IIRC.

For a schmitt trigger oscillator though I'm surprised, the hysteresis ought to overcome issues of gain and buffering??

BTW you must properly decouple any CMOS chip used as an oscillator in this way - this could be a source
of misbehaviour.

After how many weeks now?

Been busy with school... So finally I realize the problem...

the BE (Buffered Edition?)

All of my NAND, NOT etc... all of them are all BE versions!

Back to the trusty 555 and other Oscillator IC's to do the job instead... I need to get hold of the none buffered IC's! back to learning about 4000 series logic chips for me!

4000 series CMOS Logic ICs (if you want to join me)

Your circuit should have worked as described, so I suspect one of the following:

  • wiring error
  • leaky capacitor
  • mis-identified component, e.g. resistor value or capacitor value much smaller than you described, so blink rate is too fast for you to see

DC, as others already pointed out, it's to do with the fact it's buffered... I ran it through a electronics sim and it blinked fine, so it has to be that.... i'll pick up a none buffered IC on tuesday and try it again.

No, the others are wrong, using a buffered gate has nothing to do with it. A Schmitt trigger oscillator will work equally well whether the gate is buffered or not. Where it does matter whether you use a buffered gate or not is when you use an inverter in linear mode to make an oscillator, such as the usual crystal oscillator circuit (crystal + 2 capacitors + 1 or 2 resistors).