Serial port drivers not detected on MacBook

I’m not very familiar with OS X or MacBooks so may have messed up the correct or complete IDE installation when I followed the guide here and simply dragged off the Arduino application from within the downloaded .zip to the MAC’s Applications Folder as recommended… to install it alone. in any case the IDE appears to be installed Ok and is running ok. It compiles new sketches without errors but using the serial tools option I see port 1 and 6 but neither work… I do not see a USB port with “Uno” or "…tty… " anywhere in its port name. Instead the IDE generates lot of port errors when I try to download the compiled sketch into the UNO. Rebooting the MAC did not help…

is it possible this type of Retina 12 inch MacBook which has no standard 2.0/3.0 USB port on the side at all won’t support a port that is compatible with the IDE?

Here is a photo of the adapter with both HDMI and USB that is available on this USB-C Digital AV Multiport Adapter. http://www.apple.com/shop/product/MJ1K2AM/A/usb-c-digital-av-multiport-adapter

update:
I posted this query on Adafruit and they pointed me back here… Then called Apple Support and the rep i spoke with there ran it up the flagpole and no one there at Apple this evening knows if it’s an install cockpit problem on my part, or a USB C dongle driver incompatibility with the IDE… So, since no one seems to know how to make it work I am beginning to think it can’t be done on a 12 inch Retina MacBook. Oh well …

Thanks JimS

I have the same issue. Not seeing the USB port even after installing the FTDI drivers.

jjuhnke:
I have the same issue. Not seeing the USB port even after installing the FTDI drivers.

Does your board use an FTDI? If you don't know post a link to where you bought it from.

I´m having just the same problem. My Mac just doesn’t recognize the arduino. I just can´t upload my code this is vary annoying.

Same problem here:

MacBook Pro, macOX 10.13.2
connecting with a USB → USB-C adaptor (tried two different ones)

Worked before with installed drivers, but now no ports are shown except cu.MALS and cu.SOC