[SOLVED] Nano Every clone with ATMega4808 not recognized

I've bought an Arduino Nano Every clone/compatible (not a standard Nano V3) that uses an ATMega4808 instead of the ATMega4809 the official Nano Every uses. This rather insignificant change of chip is detected by the Arduino IDE (v. 1.8.13) which tells me that the chip is wrong when I select "Nano Every" from the boards list and try to upload a sketch. The seller (link to the product) does not answer to my help requests. Does anybody own one of these and knows how to make it run?

Below a photo of the board. Note the small difference in pinout (4 extra pin, D22, D23, D24 and UPDI)

Hi SquareBoot,

I think that you've got a Thinary Nano Every.

Instructions for installing on the Arduino IDE are on Github here: GitHub - Thinary/ThinaryArduino: Thinary Development Board for Arduino.

I also noticed that unlike the original, the top side pins are actually labelled, nice.

Setting it as Thinary Nano Every worked immediately like a charm. Thank you!