[Solved] Out of the box Arduino Uno recognized as HID Keyboard?

Hi all,

I've just bought my first Arduino Uno.

After installing the IDE Arduino 1.0.6, I've connected the board with a USB cable to my computer.
As expected, my computer was trying to install the driver.
And... It found a driver. The board was recognized as a HID Keyboard.
I didn't get a unrecognized device or a extra COM port.
Neither I can replace the driver with the one I've downloaded with the IDE. (Got a message that the driver is not suitable for this device).

Does anyone knows what I'm doing wrong?
How can I get my board recognized as a COM port so I can program it with the IDE?
I've got the same problem on a Windows 8.1 computer and Windows 7 computer.

Thanks in advance.

Can you supply the PID and VID of the USB device.

Thanks for the reply.

This is the pid/vid:
USB\VID_03EB&PID_2042

If it matters; i've got an arduino Uno R3.

And both my pc's are 64bit.

You should be able to use Device Manager to update the driver.
Or, use Device Manager to delete the incorrect driver and then follow instructions to install the correct one:
Window Driver Install

Ray

Hi Ray,

I've tried that. But I get a message that the best driver is already installed.
If I lookup the VID/PID on the internet, it's for a Atmel LUFA Keyboard.
And I can't find this VID/PID in the INF file of the driver which i've downloaded with the IDE.

Does anybody know how I can resolve this?
Or do I have to return this Arduino to the store?

Have you check that it is not an issue of related to driver certificates as I see you post driver not suitable for this device.

Does anybody know how I can resolve this?

Delete the driver! (Del key)
Discover hardware (Device Mgr menu)
Install correct driver (manually point to files)

Hi all,

Thanks for all the replies. I found a solution. Proto-pic pointed me to the VID/PID.
The one I have was not the standard for Arduino Uno.
So I guessed there is something wrong with the Firmware.
I've downloaded dfu-programmer-win-0.7.0. And uploaded the firmware from the IDE.
(Following this link)

After I rebootded the Arduino, it was recognized directly.

Now I have the VID and PID 2341/0010