Sublime Text 3 problemas y soluciones

Tengo un problema con el ST3 que no tiene el ST2. Tal vez sea porque es una BETA.

El probelma esta cuando al compilar se generar errores. En ST2, los errores remarcan lineas de código y resulta muy fácil identificar el problema pero en ST3 no hace nada de eso. Si alguien lo usa, tiene ese error?

Asi es como aparecen los errores en ST3. No tengo el ST2 en esta PC asi que luego posteo algo en ST2 para que se vea la diferencia. |500x288

A mi si me muestra la linea de error.

Posiblemente es problema es del pluging

ST3.png|1219x1021

Recuerdo que cuando me sucedía eso era porque tenía mal configurada esa opción que aparece en la foto: cuando la dejé como está en la imagen todo funcionó igual, no sé si será lo mismo que te sucede. Estás usando la versión del repositorio con las ultimas modificaciones del Stino?

arduinost3.png|436x154

Bueno como reporta el ST3 de Max no es como lo hace conmigo. Estoy lejos, voy a seguir investigando. No me molestaba al comienzo porque es notablemente mas veloz que el ide. Pero con los programas comienzas a perder tiempo ubicando las fallas.

Pues a mí me ocurre que además me da los números de línea mal (unas 5-10 líneas más de la que efectivamente tiene el error). :o ¿A que vamos a tener que regresar al sublime 2? :angry:

Ellos mismo nos advirtieron esta en Beta.

puedes escribirle a autor del plugin aquí: https://github.com/Robot-Will/Stino yo he solucionado varios problemas escribiéndole, en no más de 3 días (aunque ahora me parece que está de vacaciones, él es de China)

Como ninguno de los dos ha dicho que versión del plugin están usando es difícil saber el problema. De seguro surbyte tiene una versión diferente a la de Max

La última actualización del plugin fue en diciembre, todos tienen esa versión instalada?

Yo uso Stino. Como se la version?

A mi me paso algo muy raro con el Sublime 2...

Agregue la libreria de watchdog... y lo complila, pero por alguna razon, no lo carga al arduino...

Fui al arduino ide... y lo cargo y funciona adecuadamente... Ni idea que suceda.

No sé porque tenía la sensación de haber visto un número de versión, quedé un poco confundido con tanto software. Pero como no sale, es mejor bajar y actualizar los archivos con las últimas correcciones (de la rama new-stino)

por lo menos últimamente yo no he tenido problemas y cuando no me mostraba los errores anteriormente, como comenté mas arriba era por tener cambiado "Programmer" que no viene por defecto en AVRISP mkII

podes poner un link gepd?

Este sería el link para la descarga: https://github.com/Robot-Will/Stino/archive/new-stino.zip

Dejo las instrucciones de instalación traducidas, ya que por el momento solo se puede hacer manualmente.

  1. Deshabilita tu actual instalación para evitar problemas con el menú:
  • Click en el menú* Preferences->Package Control->Disable Package->Arduino-like IDE*
  1. Instalar desde la nueva rama new-stino:
  • Descarga la nueva rama new-stino de Stino como un archivo zip, y después extraerla
  • Click en el menú Preferences->Browse Packages.
  • Copiar la carpeta Stino-new-stino extraída, en la carpeta Packages
  • Reiniciar Sublime Text
  1. Configura tus carpetas de trabajo:
  • Carpeta Arduino (IDE): Click en el menú Arduino->Preferences->Select Arduino Application Folder
  • Carpeta de Sketchbook: click en el menú Arduino->Preferences->Change Sketchbook Folder
  • Carpeta de Compilación: click en el menú Arduino->Build Options->Select Build Folder
  • Forzar actualización de menú: click en el menú Arduino->Update Menu

Estás listo para probar la nueva versión!

Por favor ten en cuenta que la instalación de Stino no será actualizada automáticamente en este caso.

Para mantener tu instalación al día:

  • Click en el menu Preferences->Package Control->Remove Package->Stino
  • Continuar desde el paso 2

Para volver a la versión estable/vieja de Stino:

  • Click en el menú Preferences->Package Control->Remove Package->Stino
  • Click en el menú Preferences->Package Control->Enable Package->Arduino-like IDE
  • Reinciar Sublime Text

Bueno he seguido los pasos 2 veces y no logro que funcione bien ST3 cuando aparece un error. Algún paso no lo doy correctamente.

Adrede he generado un error en el código y no muestra la línea como si lo hace el ST2

Seria una lastima desinstalar todo para volver al ST2

Tengo ST2 en mi taller donde trabajo, y en mi casa experimento con ST3 pero no hay caso, pero evidentemente algo no he hecho correctamente. Cambió asi que estoy con el nuevo Stino pero sigue sin funcionar.

Y ahora si dejo una imagen de como quedó |500x259

Eso os pasa por no usar el IDE, jajaja

Es broma, pero no me he podido contener jajaja

Aun con todo me quedo con ST3 en lugar del IDE.

Tanto asi que cuando voy a escribir aquí me cuenta porque pienso que es el ST3, pienso que si abro un { se cierra solo o si coloco " automaticamente coloca la otra comilla ("").

El ST3 compila pero esta funcionando igual que el IDE de carmeloco, entonces no veo la gracia jajaja

Me entiendes carmeloco, asi y todo funcionando mal, o mejor dicho que cuando se produce un error no resalta la línea del fallo, compila más rapido y se ve en colores mas agradables (no tiene mucha importancia), tiene ayuda tipo eclipse que el IDE no (puede no ser relevante para muchos), y varias ventajas mas. Para mi vale la pena.

Tambien uso el ATMEL STUDIO 6.2 SP2 (ultima versión) pero lo que no uso es el IDE.

La velocidad con la que se trabaja. Una vez que se la prueba no hay marcha a atras.

Alex.

El IDE, no resalta la línea, pero te dice el número de línea donde está el error. Si pones en preferencias que muestre los números de línea, es fácil de encontrar el error.

El IDE ha mejorado muchísimo en la versión 1.6.0, aunque sí que se le echan en falta cosas como autocompletar el comando con tabulador, cosa que sí que he visto en otros entornos.