Trouble with Arduino UNO R3 + EasyVR Shield

Hello. First time posting and new to Arduino.

I have gotten my Arduino to work when it's connected to my PC on its own. When I connect my EasyVR Shield, VR Commander won't connect. I've tried switching coms, tried the jumper on PC, SW, HW, UP (pretty sure it's supposed to be on PC for the original connection) but Commander still won't connect. I just get an Error message whenever I hit "connect". (I'd post the error here now but I'm at work and can't remember exactly what it said. It was something along the lines of "cannot connect at com1. operation was successful" (?)) Tried running Commander in admin mode, switched from my laptop to my htpc....I just can't figure it out. I am also fairly certain that I have downloaded all of the proper programs/drivers from Veeear. I'm wondering if I don't have a necessary bridge driver or something.

When I try the arduino program with the VR shield connected it gives me the "not in sync" error which I assume is normal.

I'm trying to control a string of RGB LED's and a water pump run off of a relay switch so I don't think the programming will be that complicated but I can't even start on it until I get Commander to recognize the arduino/VRshield combo.

Any help would be greatly appreciated.

Ben

– Mods, bust us up to “Projects” –

While I haven’t got that stinker going yet, now is a good of time as any. The first thing is that the microphone needs to anchored to “something”. If not, it is only static to this “VR” thing is going to hear. A hole in something with paper holding it in is better than hanging on the end of the wire. It will not train that way.

Anyhow, if you do not mind a lab partner, I will work with you on this. I suspect other than a couple of links to Sparkfun, there is not too much available other than that monster manual that reads like the Atmega sheets (Good, but no quickstarts).

Okay. I am up and running in default.

I connected the Uno to the Arduino IDE and selected EasyVR Bridge from the EasyVR Library and uploaded the sketch to the Uno. Then, I connected the EasyVR shield to the Uno with the head J1-4 set to PC. I then opened EasyVR Commander selected the Com Port that the Uno is on and pressed connect. There is a "Ready" and "Connected to COM8" in the info ribbon at the bottom of the EasyVR Commander window.

With the microphone secured, I select Index 1 Wordset that has 8 default commands that will show in the other window. I click the "Test Wordset" and speak one of the 8 displayed commands and the word you spoke should highlight flash a few times.

I will definitely try to anchor the mic to something. I guess I understand that because everything that I've read about the mic says that it is quite a picky little piece of equipment.

I don't think that the mic reading static (when un-anchored) would prohibit the commander from connecting to the arduino/VR. When I had it all connected to my laptop, I got the ribbon to at least acknowledge that I had the "AVR/arduino Uno available on comX". It still wouldn't connect though. I would hit "connect" and I would still get an error. The only button that is available is the "connect" button. Everything else is grayed out.

When I get home I will try to run through it using that same sequence that you did.

What OS are you using? I'm running Win7x64.

You're right about the manual that comes with it. That thing is a beast.

What OS are you using? I'm running Win7x64.

Just an WinXP on a Compaq (Yeah, a little dated). I have a Vista Win7 and Linux available for testing purposes.

Well...I anchored the mic. I uploaded the Vrbridge sketch to the arduino and then attached the shield. When I ran commander and hit connect it gave me the error: Could not open the port "COM6" -- A device attached to the system is not functioning

When I hit connect again, it gives me the error: Could not open the port "COM6" -- The operation completed successfully.

I hope my shield isn't broken.

How are you getting along with yours?

I just tried to connect commander with just the arduino with the EasyVR sketch uploaded on it just to see what would happen and I got this error:

EasyVR Error.PNG

What happens when you load the other Test sketch and open serial monitor?

Well…When I have the Vr Test sketch uploaded, and try to connect to Commander I get the “access is denied” error.

When I uploaded the sketch to the lone arduino and ran serial monitor it said that EasyVR not detected. I didn’t have the shield on the arduino board so that is understandable I guess. When I ran it after I connected the shield, I got “Serial Port ‘com6’ already in use. try quitting any programs that my be using it.” I may just be using the monitor wrong though.

I tried leaving the shield on and took the jumper off completely and uploaded the test sketch and ran the monitor again and this time it sent me the 2nd png I attached. I kept moving the jumper around (because I’m impatient) and it gave me a couple different read outs (png3). The goofy little A’s and symbols are all when I moved the jumper back to the PC position.

vr test.PNG

serimon1.PNG

serimon2.PNG

When the Test sketch is run, the jumper needs to be in the SW position to use the software serial, HW may work but it might conflict with the serial monitor.

What has me concerned is the extra characters you are receiving with the shield not attached. With the shield off, try uploading the AnalogReadSerial (In Basics) and open the serial monitor. After some buffer garbage, there should only be 3 digit numbers streaming from the top left down.

The AnalogReadSerial worked fine. Just scrolled 3 dig numbers quick.

I ran the VR test sketch again with the jumper on SW and got the second png attached.

ARS.PNG

vrtest 2.PNG

The AnalogReadSerial worked fine. Just scrolled 3 dig numbers quick.

I ran the VR test sketch again with the jumper on SW and got the second png attached.

I am glad it is not your Arduino. When you hook up the shield to the Arduino, does the D6 LED (next to R14 and LINE OUT) on the back of the EasyVR Shield light up?

Yeah. That lights up.

And, since you have an Uno, you have not have any FTDI / USB2UART device? Does your Uno have the Atmega328 DIP (Big chip you can pull out)?

The Uno that I'm using is the smd edition. That one doesn't have the atmega. I have an uno with the atmega328P-PU though.

I tried that one first and and had trouble with it so I switched to the SMD. My project is going to be a semi-permanent install so I just figured I'd go with the "latest and greatest" if you will.

Well, we were going to try to burn the latest and greatest firmware, but when I got to the directory where the hex is supposed to reside, it was not there. I contacted them, but since they are EU based, I suspect it will be a day or two for a response.

ATMEGA328P-PU, PERFECT. After I test it out the firmware upload on myside, we will need to convert that Arduino into a USB2UART device (just pull the ATMEGA328 out).

One other thing we can mess with. In the EasyVR Test sketch in the void_setup() try adding a 50ms delay below port.Begin(9600).

Serial.Begin(9600);
port.Begin(9600);
[b]delay(50);[/b]

Then upload and open serial monitor.

I actually tried changing the delays to 50 then to 100. I figured maybe my chip was a dumby and needed a little more time. but that just gave me the same kind of reads.

I really appreciate your help. I'm just too inexperienced with this stuff to properly trouble shoot.

Not a problem. As I said, I had be stalling working with this for some time and you were the perfect opportunity to get back to it.

I'll let you know when Veear replies.

Okay, I got the goods. I have attached the EasyVR firmaware to this post so download it and place it in Program Files\Veear\EasyVR Commander directory. Then open up a command prompt in that EasyVR Commander directory.

For your hardware, disconnect the USB move the jump to UP on the EasyVR Shield connected to the Arduino. Reconnect the USB and note which COM port that is being used.

Go back to the command prompt window in the EasyVR Commander directory and type:

VeeLoader -p COMx -c EASYVR_FW.HEX -nofast

Where x is the COM PORT your Arduino/EasyVR is on.

The firmware should upload to the EasyVR. If not, disconnect the Arduino for a couple seconds then plug it back in and try again.

EASYVR_FW.HEX (455 KB)

AWESOME!