Uninstall deleted multiple other programs

I'm reporting this as a bug and warning to others, not looking for any solution. I see someone else reported something similar 6 months ago but it seemed to be dismissed at the time as user error. I assure you, this was not user error, and maybe there's something different about how my environment is setup that caused the issue, but it's not something I can reproduce to identify the cause.

I had installed the new beta version of the IDE (did not previously have the stable release version installed). I install programs that are temporary or can easily be reinstalled in an "E:\Programs" folder to keep my C:\ drive SSD as clean as possible. I had quite a few other programs in this folder such a KiCad, IrfanView and OpenSCAD and a dozen others, mostly freeware thanks goodness and fairly easy to reinstall without any data loss. I have lost one old program, my Phoenix RC flight simulator, which may be hard to recover.

I tried to add the board manager for the Seeduino xiao and it wouldn't install. Figuring it might be a beta issue, I decided to revert to the current stable release. So I went into windows add/remove programs and installed first the Arduino IDE then the Create agent. When they finished uninstalling, I noticed several of my other program shortcuts had reverted to the standard window white piece of paper icon, which indicated a lost shortcut.

So looking back into my "E:\Programs" folder, sure enough, it had been wiped clean except for one folder. Why that one folder survived I'm not sure, but the other dozen or so programs are now gone, with only my shortcuts remaining to point to where they once lived, and my system is now a mess as a have a lot of programs that have just been deleted without properly uninstalled.

So beware, if you are uninstalling, make sure you have a backup of everything that lives under the same root folder as the Arduino programs. This is a serious flaw somewhere along the line.

You know the really sad part? The Xiao board installer still doesn't work with the current Arduino IDE either :frowning:

Check your recycle bin.