Windows 7 and Arduino UNO

I recently got an Arduino UNO and plugged it into my windows 7, downloaded the latest IDE, and tried to install the driver. However, Windows said that there were problems installing the driver, and I can't load my sketch to my Arduino because I can't select COM3, the correct serial port, or any other of the serial ports for that matter - Tools > Serial Port is grayed out and not clickable. How do I solve this problem?

u need to install yours drivers manual :

START+R> devmgmt.msc>Ports (COM & LTP) > Arduino UNO> drivers> instal driver and point your arduino uno drivers \Tools\xxx\drivers 'xxx' your arduino IDE version

Follow these instructions

I re-installed the drivers. It didn’t work. Tools > Serial Port is still grayed out, I still get the error when I try to load my sketch to the Arduino. What else can I do?

Did you follow the instructions in the link that I posted? The only time that I have seen the serial port grayed out is then the drivers are not installed.

Reading the forum(s), I discover I am not the only one with trouble with the Serial Port. Amazing how many hours are wasted because the system does not work properly!
Using W7, I did download the system. The Serial Port was grey, meaning no communications with the board. After a re-installation, I got COM8 and all worked OK for several hours, I could load and run my own sketch. All good. And then, it happens again, Serial Port is grey. Done all possible, upgrade driver through device manager, etc, etc… to no effect.
Finally after a complete re-download of everything, when unzipping I now have an error message: “Could not find the main class: processing.apps.Base. Program will exit.”
There will shortly be a very cheap Arduino board on the market… Life is far too short for wasting time with gizmos that do not work…
Has anyone any idea? Thank you.

So, what I did, ( and this may help you too, com64, ) was I had to UNINSTALL the driver. Then I reinstalled the driver, and Windows 7 finally got it right! Of course, it might have been simpler ( and has been more well-documented ) if I had had a Windows XP, which I sincerely miss, but that's not the point.

By the way, ^_^ hodes [cathodes] are negative, are the shorter wire on an LED, and are represented by a black wire, and anodes are positive, are the longer wire on an LED, and are shown by a red wire. But it's different for RGB LED's. Yes, it's confusing. But now I'll just get back to blinking my LED's!

The main thing is to UNINSTALL the driver BEFORE REINSTALLING the driver. If Windows 7 recognizes the Arduino but says there are problems, the driver was not completely/successfully installed, and must be uninstalled before being reinstalled.

Thank you. Did all that twice (uninstall and restart from fresh). When connecting the USB cable, the computer gives the ‘normal’ sound b but nothing on the Device manager. Giving up now until I find a ‘proper’ USB interface that works. Life is too short to waste time with devices that are not properly designed. com64

There is something wrong with your system and it's handling of the USB ports.

You can go into device manager, delete all the USB root hubs and reboot. Windows will detect the root hubs and enumerate them.

After that, follow the steps exactly as indicated at and see what happens.


I just replied to com64's thread and was curious as to what the ending virtual com port (Com3 bad?) that works.

just something off topic, but is it possible that i have never done that, and still got everything perfectly running?

i have never installed any driver for my arduino, and still i have never encountered any tiny problem :o

this is an older post but I'm in the same boat. Same specs (right down to the port # chosen). I've only done this a thousand times (with unos, dues diecimilas, megas, even sanguinos), and all of a sudden nothing! with any of these. Have tried it on a number of systems and I know the boards are ok because I can still work with them on the mac side of things. Now trying different IDE's - the legacy stuff seems to have disappeared from the arduino site so I'm having to get V17 thru V23 from other places.

Success! In my case it was a Renesas usb driver for other devices (like mice and keyboards). I don't remember installing this so i may have installed itself when a certain mouse or keyboard was used. Removing this has killed the use of all my chosen USB peripherals and I'm now searching for compatible hardware and drivers that will still allow the arduino to function as well. I though this was the whole point of multiple ports - so that you could run different hardware. What I don't know is if this is an issue with the arduino implementation of the port calls or an overbearing Renesas driver hammering away on all ports, drowning out meek whimpers from the arduinos.