WLED ESP32 stützt bei Steuerung ab

Hallo,

Ich nutze einen ESP32 mit WLED (Version 0.12.0) um meine WS2812b LEDs über das WLAN zu Steuern.
Mein Problem ist das bei der Verstellung der Helligkeit, das an und Abschalten und beim Auswählen der Favoriten der ESP rebooted wenn ich aber die Farbe und Effekte manuell einstelle Funktioniert alles wie es soll.
Somit kann es ja keine Überbeanspruchung sein die LEDs werden logischerweise über ein extra Netzteil betreiben die Stromversorgung sollte also kein Problem sein.
Ist es nur eine reine Software Sache oder übersehe ich was?

Danke im Voraus

Ich betreibe WLED mit einem ESP8266 und habe keine Probleme. Diese Software-Version könnte aber eine ältere sein, da schon über ein Jahr ohne Probleme im Einsatz.

Es könnte sein, dass wenn du „händisch“ die Werte änderst, viel langsamer bist, als wenn die Software das übernimmt. Also ist es schon möglich das die Spannung zusammen bricht. Du könntest einen größeren Elko an der ESP Versorgung probieren, um die Spannung kurzzeitig zu halten.

Danke für die Antwort

Ja hatte davor auch einen ESP8266 da lief es ohne Probleme benötige den aber für ein anderes Projekt deshalb der ESP32.

Teste ich mal aus ich versuche es auch mal nur mit dem ESP also ohne WS2812b… wenn das Problem da auch noch besteht Teste ich mal eine andere Version

Ich vermute da eher ein Problem in deinem Sketch, der den ESP32 zum Absturz bringt.

die übersiehst was in deinem Sketch. Reine Softwaresache auf deiner Seite.

Danke

Es ist kein Sketch an sich sondern eine .bin (binär) Datei

Ach....Und wie entwickelst du den ?

Die gibt es fertig zum Download.

Und eine Anleitung dazu:

1 Like

Na dann hat der TO doch alles fertig zum Aufbau.
Da würde ich mich bei Problemen an den Autor wenden. Der kennt sein Programm.

Natürlich. Dennoch kann man zusätzlich auch hier fragen, ob jemand ähnliche Probleme hatte und evtl. eine Lösung dazu kennt.

Man könnte auch den ESP32 separat versorgen (z.B. USB) und den Streifen über das Netzteil. GND miteinander verbinden. Wenn der Fehler verschwindet, kann das Problem die Versorgung des ESP32 sein.

Vorsicht, immer erst die LED-Streifen versorgen, danach den ESP32. Sonnst wird die erste LED Schaden nehmen, da sie sich über den Datenpin versorgt. Ein Widerstand in der Datenleitung, hilft gegen den Tod der ersten LED.

1 Like

Hallo,

Wenn das Netzteil mit dem 8266 läuft sollte es auch mit dem ESP32 ok sein.
ich kann mir aber nicht vorstellen das das Binärfile vom ESP8266 auf einem ESP32 läuft. Oder hab ich was übersehen.
Heinz

Lt. Dokumentation soll er beide Controller abdecken.

Danke

Der ESP wird separat versorgt und der Widerstand ist auch vorhanden und die LEDs hängen dauerhaft am Strom nur der ESP wird abgeschaltet

Ja das is klar habe natürlich dann die .bin Datei für den ESP32 genommen

Also habe den ESP gerade mal ohne LEDs also „nackig“ getestet Problem bleibt das gleiche also kann es ja nicht an der Stromversorgung o.ä. Liegen wird wohl doch Softwareseitig sein.
Ja hätte ich eher testen können bevor ich mich ans Forum wende.

Danke für eure Hilfe

Mach Dir keine Gedanken....
KAnnst Du mal schauen, ob Deine Hardware passt? - incl. Softwarestand:
https://kno.wled.ge/basics/compatible-hardware/