CMOS camera sensor issue

Hi there,
I bought the following scope from AliExpress "Eakins" seller two years back and since the day I received it was not working.



Camera was showing pink and green lines as seen below.

So I complained to them and they sent me a replacement sensor board, which I fitted as per the factory installation and saw the same result pink and green lines.


They wanted me to post it for inspection at that time but with the pandemic the postal services from where I live to China was suspended and I could not send.

So I didn't throw it away and kept it with me, today I had some time and checked the ribbon cable connecting the motherboard and the sensor board and noticed that there is no connectivity in any pins. So I tested the ribbon cable and it was all good.
For my surprise I realized that the ribbon cable was installed wrong way up. So no wonder when installed as per factory fitting it had no connectivity.

So I installed the ribbon cable correct way and with the lens removed I could see light orange screen in the monitor now



and those pink and green lines were gone.
I can see color changes when I move my finger on top of the sensor.

But now the issue is after installing the lens I only see a black screen.

what might be the cause of this?
Have I destroyed the both factory installed and spare one by installing the ribbon cable wrong side and powering up?
Or is it the lens?

An insight would greatly help.

Impossible to say .

Looks like a dustbin job , always an issue when buying cheap items Iā€™m afraid , lot of us have been there .

Hi @hammy
I was able to resolve the issue.
Good thing I didn't dustbin it and kept it with me 2 years.
My post in eevBlog forum

Thanks!

For completeness -

"It was the lens.
I had to adjust length between the lens and the sensor and it worked."

1 Like