mega8 got weird behave

I have an arduino clone based on mega8. Recently I noticed that mega8 is replaced by mega8a, then I tried a mega8a with the same bootloader burned in mega8. After several simple downloading tests(such as BLINK and FADE), my arduino clone turns out weird. For example, when I have downloaded the example FADE, my arduino don't actually fade but blink randomly(maybe not, hard to define), of course the blink behavior turns out it isn't the BLINK example. I also used oscilloscope to measure. The result is not only the pin9 blink(strange squarewave) but also other pins are blinking, such as pin10, 11, 12 and 13. Another example is that says after downloading BLINK(I changed pin13 to pin9), pin9 just go HIGH forever.
I tried physically reset after those weird behavior, then my arduino behave correctly, and it seems the programme uploaded last time with weird behavior turns out upload successfully.
I attached my arduino clone below, I can also provide other picture if needed. Any suggestion is aqqreciated!

These are "old cores" but I went googling and found:

n important difference, however, is the ATmega8 A no longer has the
internal short circuit between VCC and AVCC.

What this means is that you must supply AVCC, otherwise not PortC
work. If you want to use the ADC as per the wiring is
Data Sheet attached.

Google translated from German, so it's WYSIWYG

Ray

Hi Ray,
Thanks for reply, I connected AVCC to VCC on my PCB, and I'm wondering if my bootloader is right. I modified it from optiboot, and may cause some problem.

Seems the cost of the time you have already wasted is worth a lot more than the saving in price compared to a real Arduino.

...R

I modified it from optiboot, and may cause some problem.

Robin2 has a point about time spent, but we all know that sometime the journey is the value and the time considerations get written off to continuing education XD

i think this thread may be useful:
http://forum.arduino.cc/index.php?topic=52873.0

Ray

Update!
I try to burn "optiboot-v5.0a" on both mega8 and mega8a through both USBtinyisp and ArduinoISP I got, but still no luck.
My arduino clone sometimes behaved right: click download on Arduino IDE --> led on pin13 blinks three times indicates bootloader start --> Arduino IDE says done uploading --> led on pin9 begins to FADE. But sometimes after Arduino IDE says done uploading, I just got a weird behavior arduino clone(maybe I could upload some video).
I also saw some different apperance(not all those apperance cause weird behavior arduino) from the right apperance I stated above(if I said right). Sometimes led on pin13 blinks 4(or 1+3) times after click download on Arduino IDE. Also, led13 may bilnk 3 times second time after Arduino IDE says done uploading, after this the programme on arduino start run correctly.


This is my weird behavior arduino clone, I uploaded FADE on pin9 but got this...

Update!
As the video above, when I move my finger to my arduino clone board, both led on pin9 and pin13 are blinking. I try this on today morning and got such result: when my finger is close enough(but no touch) to the XTAL pin aka x1 and x2, the leds are blinking madly. All those happened after arduino behave weird. No such madly blinking when I try to move my finger to XTAL on normal conditions.